diff options
author | DX37 | 2020-06-15 12:32:49 +0700 |
---|---|---|
committer | DX37 | 2020-06-15 12:32:49 +0700 |
commit | 524b31097164b6e32623cd661fb879fb54f80ab1 (patch) | |
tree | db0364d79f4407f695daedca47e046be17462e1d | |
parent | eeec99eafd36c654d3bfe87e0bcef81ac4345878 (diff) | |
download | aur-524b31097164b6e32623cd661fb879fb54f80ab1.tar.gz |
fixes
- apply part of gcc10 pull request fix (https://github.com/hishamhm/htop/pull/981)
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 8 | ||||
-rw-r--r-- | gcc10-fix.patch | 29 |
3 files changed, 39 insertions, 2 deletions
@@ -1,7 +1,7 @@ pkgbase = htop-temperature pkgdesc = Interactive process viewer with added support for CPU temperature pkgver = 2.2.0 - pkgrel = 3 + pkgrel = 4 url = http://hisham.hm/htop/ arch = i686 arch = x86_64 @@ -20,9 +20,11 @@ pkgbase = htop-temperature options = !emptydirs source = http://hisham.hm/htop/releases/2.2.0/htop-2.2.0.tar.gz source = htop-temperature.patch + source = gcc10-fix.patch source = 0001-fix-option-string.patch sha256sums = d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57 sha256sums = a4c9dfbc3c2f7e08904656b53b9c08d19014cf6238fb75f1ed5ecbef2905964c + sha256sums = abe64433c701b348b4ea032b9cf4c64d19f2aa059a4fca1554efb283db2f7c0e sha256sums = 343cfd8e01f2d47e54b38f725bb05a9825511b502acdb6803507e5fa4d52bed7 pkgname = htop-temperature @@ -4,7 +4,7 @@ _pkgname=htop pkgname=htop-temperature pkgver=2.2.0 -pkgrel=3 +pkgrel=4 pkgdesc="Interactive process viewer with added support for CPU temperature" arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h') url="http://hisham.hm/htop/" @@ -18,9 +18,11 @@ conflicts=($_pkgname) options=('!emptydirs') source=("http://hisham.hm/$_pkgname/releases/$pkgver/$_pkgname-$pkgver.tar.gz" "htop-temperature.patch" + "gcc10-fix.patch" "0001-fix-option-string.patch") sha256sums=('d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57' 'a4c9dfbc3c2f7e08904656b53b9c08d19014cf6238fb75f1ed5ecbef2905964c' + 'abe64433c701b348b4ea032b9cf4c64d19f2aa059a4fca1554efb283db2f7c0e' '343cfd8e01f2d47e54b38f725bb05a9825511b502acdb6803507e5fa4d52bed7') prepare() { @@ -30,6 +32,9 @@ prepare() { # Add CPU temperature patch. patch -Np1 < "$srcdir"/htop-temperature.patch + + # Add gcc10 build patch. + patch -Np1 < "$srcdir"/gcc10-fix.patch } build() { @@ -37,6 +42,7 @@ build() { ./autogen.sh ./configure \ + CFLAGS="-O2 -fno-common" \ --prefix=/usr \ --sysconfdir=/etc \ --enable-cgroup \ diff --git a/gcc10-fix.patch b/gcc10-fix.patch new file mode 100644 index 000000000000..691bffc31341 --- /dev/null +++ b/gcc10-fix.patch @@ -0,0 +1,29 @@ +diff --git a/CRT.h b/CRT.h +index 29ea885..fd4004d 100644 +--- a/CRT.h ++++ b/CRT.h +@@ -143,7 +143,7 @@ extern const char **CRT_treeStr; + + extern int CRT_delay; + +-int* CRT_colors; ++extern int* CRT_colors; + + extern int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT]; + +@@ -153,13 +153,13 @@ extern int CRT_scrollHAmount; + + extern int CRT_scrollWheelVAmount; + +-char* CRT_termType; ++extern char* CRT_termType; + + // TODO move color scheme to Settings, perhaps? + + extern int CRT_colorScheme; + +-void *backtraceArray[128]; ++extern void *backtraceArray[128]; + + #if HAVE_SETUID_ENABLED + |