summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDX372020-08-31 16:12:29 +0700
committerDX372020-08-31 16:12:29 +0700
commit165894ffaa940e7b90ccd20054e33532a0bd84e0 (patch)
tree22bd743137423e059da462204c0867bfe4bfebd5
parent8184835952b69ce5c50a15432cae848f42256275 (diff)
downloadaur-165894ffaa940e7b90ccd20054e33532a0bd84e0.tar.gz
fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--htop-3.0.0.tar.gzbin0 -> 179371 bytes
-rw-r--r--htop-temperature-rpi.patch48
4 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ca717559719..54bf475b8a1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,7 +20,7 @@ pkgbase = htop-temperature-rpi
source = htop-temperature-rpi.patch
sha256sums = 1c0661f0ae5f4e2874da250b60cd515e4ac4c041583221adfe95f10e18d1a4e6
sha256sums = e31d8ab3fc41048b9dce0016cbb8facb6d0e62cf4a91c295b99f268cf120f1fc
- sha256sums = 83eed3420c20c29016f56d5bb56483fb1194d409346ddfe76522e4c351f1b619
+ sha256sums = 42842d7cc73106e325dfa3335f34ad13818fd0b59e91f01d1377d26611369969
pkgname = htop-temperature-rpi
diff --git a/PKGBUILD b/PKGBUILD
index 08b2652e41c6..d748e715a963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ source=("https://github.com/htop-dev/htop/archive/${pkgver}/${_pkgname}-${pkgver
'htop-temperature-rpi.patch')
sha256sums=('1c0661f0ae5f4e2874da250b60cd515e4ac4c041583221adfe95f10e18d1a4e6'
'e31d8ab3fc41048b9dce0016cbb8facb6d0e62cf4a91c295b99f268cf120f1fc'
- '83eed3420c20c29016f56d5bb56483fb1194d409346ddfe76522e4c351f1b619')
+ '42842d7cc73106e325dfa3335f34ad13818fd0b59e91f01d1377d26611369969')
prepare() {
cd "$_pkgname-$pkgver"
diff --git a/htop-3.0.0.tar.gz b/htop-3.0.0.tar.gz
new file mode 100644
index 000000000000..1585f2435227
--- /dev/null
+++ b/htop-3.0.0.tar.gz
Binary files differ
diff --git a/htop-temperature-rpi.patch b/htop-temperature-rpi.patch
index 18d8ec75551e..3c36c76736e6 100644
--- a/htop-temperature-rpi.patch
+++ b/htop-temperature-rpi.patch
@@ -86,12 +86,33 @@ index 5fb2f09..fc40b2a 100644
SWAP,
PROCESS,
PROCESS_SHADOW,
+diff --git a/Makefile.am b/Makefile.am
+index d455b4d..2f6dd75 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -49,6 +49,7 @@ linux_platform_headers = \
+ linux/LinuxProcessList.h \
+ linux/LinuxCRT.h \
+ linux/Battery.h \
++ TemperatureMeter.h \
+ linux/PressureStallMeter.h \
+ zfs/ZfsArcMeter.h \
+ zfs/ZfsCompressedArcMeter.h \
+@@ -59,7 +60,7 @@ all_platform_headers += $(linux_platform_headers)
+ if HTOP_LINUX
+ AM_LDFLAGS += -rdynamic
+ myhtopplatsources = linux/Platform.c linux/IOPriorityPanel.c linux/IOPriority.c \
+-linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c \
++linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c TemperatureMeter.c \
+ linux/PressureStallMeter.c \
+ zfs/ZfsArcMeter.c zfs/ZfsCompressedArcMeter.c zfs/ZfsArcStats.c
+
diff --git a/TemperatureMeter.c b/TemperatureMeter.c
new file mode 100644
-index 0000000..9ee9185
+index 0000000..872b92c
--- /dev/null
+++ b/TemperatureMeter.c
-@@ -0,0 +1,100 @@
+@@ -0,0 +1,85 @@
+/*
+htop - TemperatureMeter.c
+(C) 2013 Ralf Stemmer
@@ -202,27 +223,6 @@ index 0000000..b86ddd8
+extern MeterClass TemperatureMeter_class;
+
+#endif
-diff --git a/Makefile.am b/Makefile.am
-index d455b4d..2f6dd75 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -49,6 +49,7 @@ linux_platform_headers = \
- linux/LinuxProcessList.h \
- linux/LinuxCRT.h \
- linux/Battery.h \
-+ TemperatureMeter.h \
- linux/PressureStallMeter.h \
- zfs/ZfsArcMeter.h \
- zfs/ZfsCompressedArcMeter.h \
-@@ -59,7 +60,7 @@ all_platform_headers += $(linux_platform_headers)
- if HTOP_LINUX
- AM_LDFLAGS += -rdynamic
- myhtopplatsources = linux/Platform.c linux/IOPriorityPanel.c linux/IOPriority.c \
--linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c \
-+linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c TemperatureMeter.c \
- linux/PressureStallMeter.c \
- zfs/ZfsArcMeter.c zfs/ZfsCompressedArcMeter.c zfs/ZfsArcStats.c
-
diff --git a/linux/Platform.c b/linux/Platform.c
index 0f59fed..49038b2 100644
--- a/linux/Platform.c
@@ -232,7 +232,7 @@ index 0f59fed..49038b2 100644
#include "zfs/ZfsCompressedArcMeter.h"
#include "LinuxProcess.h"
+#include "TemperatureMeter.h"
-
+
#include <math.h>
#include <assert.h>
@@ -119,6 +120,7 @@ MeterClass* Platform_meterTypes[] = {