summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDX372020-09-04 17:56:45 +0700
committerDX372020-09-04 17:56:45 +0700
commit6ce000a29fe1cecdaf285f706836a343ef6920d8 (patch)
tree9e28f382016522aa9355b5c69817459b66c935e8
parent165894ffaa940e7b90ccd20054e33532a0bd84e0 (diff)
downloadaur-6ce000a29fe1cecdaf285f706836a343ef6920d8.tar.gz
changes
- 3.0.1 - fix all patch warnings
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--htop-temperature-rpi.patch30
3 files changed, 21 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54bf475b8a1f..b742526d4c2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = htop-temperature-rpi
pkgdesc = Interactive process viewer with added support for CPU temperature. Version for gathering Raspberry Pi CPU temperature from thermal_zone0
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://htop.dev/
arch = i686
@@ -15,11 +15,9 @@ pkgbase = htop-temperature-rpi
optdepends = lsof: show files opened by a process
optdepends = strace: attach to a running process
options = !emptydirs
- source = https://github.com/htop-dev/htop/archive/3.0.0/htop-3.0.0.tar.gz
- source = 0001-Increae-the-size-of-sysfs-power-supply-path-buffers.patch
+ source = https://github.com/htop-dev/htop/archive/3.0.1/htop-3.0.1.tar.gz
source = htop-temperature-rpi.patch
- sha256sums = 1c0661f0ae5f4e2874da250b60cd515e4ac4c041583221adfe95f10e18d1a4e6
- sha256sums = e31d8ab3fc41048b9dce0016cbb8facb6d0e62cf4a91c295b99f268cf120f1fc
+ sha256sums = 8465164bc085f5f1813e1d3f6c4b9b56bf4c95cc12226a5367e65794949b01ca
sha256sums = 42842d7cc73106e325dfa3335f34ad13818fd0b59e91f01d1377d26611369969
pkgname = htop-temperature-rpi
diff --git a/PKGBUILD b/PKGBUILD
index d748e715a963..40ddc62e9aa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=htop
pkgname=htop-temperature-rpi
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc='Interactive process viewer with added support for CPU temperature. Version for gathering Raspberry Pi CPU temperature from thermal_zone0'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
@@ -13,17 +13,13 @@ optdepends=('lsof: show files opened by a process'
'strace: attach to a running process')
options=('!emptydirs')
source=("https://github.com/htop-dev/htop/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
- '0001-Increae-the-size-of-sysfs-power-supply-path-buffers.patch'
'htop-temperature-rpi.patch')
-sha256sums=('1c0661f0ae5f4e2874da250b60cd515e4ac4c041583221adfe95f10e18d1a4e6'
- 'e31d8ab3fc41048b9dce0016cbb8facb6d0e62cf4a91c295b99f268cf120f1fc'
+sha256sums=('8465164bc085f5f1813e1d3f6c4b9b56bf4c95cc12226a5367e65794949b01ca'
'42842d7cc73106e325dfa3335f34ad13818fd0b59e91f01d1377d26611369969')
prepare() {
cd "$_pkgname-$pkgver"
- patch -Np1 < ../0001-Increae-the-size-of-sysfs-power-supply-path-buffers.patch
-
# Add CPU temperature patch.
patch -Np1 < ../htop-temperature-rpi.patch
diff --git a/htop-temperature-rpi.patch b/htop-temperature-rpi.patch
index 3c36c76736e6..fceec3006802 100644
--- a/htop-temperature-rpi.patch
+++ b/htop-temperature-rpi.patch
@@ -1,8 +1,8 @@
diff --git a/CRT.c b/CRT.c
-index 869573e..e6b8a75 100644
+index 0d83bf4..6574b38 100644
--- a/CRT.c
+++ b/CRT.c
-@@ -101,6 +101,9 @@ typedef enum ColorElements_ {
+@@ -88,6 +88,9 @@ typedef enum ColorElements_ {
UPTIME,
BATTERY,
TASKS_RUNNING,
@@ -12,7 +12,7 @@ index 869573e..e6b8a75 100644
SWAP,
PROCESS,
PROCESS_SHADOW,
-@@ -240,6 +243,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
+@@ -204,6 +207,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
[METER_VALUE] = A_BOLD | ColorPair(Cyan,Black),
[LED_COLOR] = ColorPair(Green,Black),
[TASKS_RUNNING] = A_BOLD | ColorPair(Green,Black),
@@ -22,7 +22,7 @@ index 869573e..e6b8a75 100644
[PROCESS] = A_NORMAL,
[PROCESS_SHADOW] = A_BOLD | ColorPairGrayBlack,
[PROCESS_TAG] = A_BOLD | ColorPair(Yellow,Black),
-@@ -308,6 +314,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
+@@ -273,6 +279,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
[METER_VALUE] = A_BOLD,
[LED_COLOR] = A_NORMAL,
[TASKS_RUNNING] = A_BOLD,
@@ -32,7 +32,7 @@ index 869573e..e6b8a75 100644
[PROCESS] = A_NORMAL,
[PROCESS_SHADOW] = A_DIM,
[PROCESS_TAG] = A_BOLD,
-@@ -376,6 +385,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
+@@ -342,6 +351,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
[METER_VALUE] = ColorPair(Black,White),
[LED_COLOR] = ColorPair(Green,White),
[TASKS_RUNNING] = ColorPair(Green,White),
@@ -42,7 +42,7 @@ index 869573e..e6b8a75 100644
[PROCESS] = ColorPair(Black,White),
[PROCESS_SHADOW] = A_BOLD | ColorPair(Black,White),
[PROCESS_TAG] = ColorPair(White,Blue),
-@@ -444,6 +456,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
+@@ -411,6 +423,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
[METER_VALUE] = ColorPair(Black,Black),
[LED_COLOR] = ColorPair(Green,Black),
[TASKS_RUNNING] = ColorPair(Green,Black),
@@ -52,7 +52,7 @@ index 869573e..e6b8a75 100644
[PROCESS] = ColorPair(Black,Black),
[PROCESS_SHADOW] = A_BOLD | ColorPairGrayBlack,
[PROCESS_TAG] = ColorPair(White,Blue),
-@@ -512,6 +527,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
+@@ -480,6 +495,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
[METER_VALUE] = A_BOLD | ColorPair(Cyan,Blue),
[LED_COLOR] = ColorPair(Green,Blue),
[TASKS_RUNNING] = A_BOLD | ColorPair(Green,Blue),
@@ -62,7 +62,7 @@ index 869573e..e6b8a75 100644
[PROCESS] = ColorPair(White,Blue),
[PROCESS_SHADOW] = A_BOLD | ColorPair(Black,Blue),
[PROCESS_TAG] = A_BOLD | ColorPair(Yellow,Blue),
-@@ -580,6 +598,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
+@@ -549,6 +567,9 @@ int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
[METER_VALUE] = ColorPair(Green,Black),
[LED_COLOR] = ColorPair(Green,Black),
[TASKS_RUNNING] = A_BOLD | ColorPair(Green,Black),
@@ -73,10 +73,10 @@ index 869573e..e6b8a75 100644
[PROCESS_SHADOW] = A_BOLD | ColorPairGrayBlack,
[PROCESS_TAG] = A_BOLD | ColorPair(Yellow,Black),
diff --git a/CRT.h b/CRT.h
-index 5fb2f09..fc40b2a 100644
+index 7d5c8ad..9ef7660 100644
--- a/CRT.h
+++ b/CRT.h
-@@ -89,6 +89,9 @@ typedef enum ColorElements_ {
+@@ -76,6 +76,9 @@ typedef enum ColorElements_ {
UPTIME,
BATTERY,
TASKS_RUNNING,
@@ -109,10 +109,10 @@ index d455b4d..2f6dd75 100644
diff --git a/TemperatureMeter.c b/TemperatureMeter.c
new file mode 100644
-index 0000000..872b92c
+index 0000000..d28169d
--- /dev/null
+++ b/TemperatureMeter.c
-@@ -0,0 +1,85 @@
+@@ -0,0 +1,102 @@
+/*
+htop - TemperatureMeter.c
+(C) 2013 Ralf Stemmer
@@ -149,16 +149,18 @@ index 0000000..872b92c
+}
+
+static void TemperatureMeter_display(Object* cast, RichString* out) {
++ (void) cast;
+ FILE *p;
+ p = popen("/usr/bin/cat /sys/class/thermal/thermal_zone0/temp", "r");
-+ if(p == NULL) return 1;
++ if(p == NULL) return;
+
+ int textColor = CRT_colors[METER_TEXT];
+ int coolColor = CRT_colors[TEMPERATURE_COOL];
+ int mediumColor = CRT_colors[TEMPERATURE_MEDIUM];
+ int hotColor = CRT_colors[TEMPERATURE_HOT];
+
-+ size_t read, len;
++ int read;
++ size_t len;
+ char *line = NULL;
+ int temperature;
+ while ((read = getline(&line, &len, p)) != -1) {