summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDawid Potocki2023-02-05 14:02:43 +1300
committerDawid Potocki2023-02-05 14:02:43 +1300
commit109a631491a65ec55325ca92c0d4b6a5a0d3c144 (patch)
tree6bc27ab3f7a8ee0b9c58c4218988c7f8c4525277
parent6c1d9b5ca66d6fade8727e856290cd71e635a129 (diff)
downloadaur-109a631491a65ec55325ca92c0d4b6a5a0d3c144.tar.gz
Update to 3.2.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--vim-keybindings.patch64
3 files changed, 40 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32024f3a9050..3c0312ea0d3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = htop-vim
pkgdesc = Interactive process viewer with a Vim keybindings patch
- pkgver = 3.2.1
+ pkgver = 3.2.2
pkgrel = 1
url = https://htop.dev/
arch = x86_64
@@ -17,9 +17,9 @@ pkgbase = htop-vim
provides = htop
conflicts = htop
options = !emptydirs
- source = https://github.com/htop-dev/htop/archive/3.2.1/htop-3.2.1.tar.gz
+ source = https://github.com/htop-dev/htop/archive/3.2.2/htop-3.2.2.tar.gz
source = vim-keybindings.patch
- sha256sums = b5ffac1949a8daaabcffa659c0964360b5008782aae4dfa7702d2323cfb4f438
- sha256sums = dd0fbe1685d4e7966c18dcfa9946da436a1d198d071def5ff7c39df8126e9483
+ sha256sums = 3829c742a835a0426db41bb039d1b976420c21ec65e93b35cd9bfd2d57f44ac8
+ sha256sums = 06eb3383e3643f0edcbf5c2b5a7ef8e261dd9f81a2435bd9a17f941583c44bd2
pkgname = htop-vim
diff --git a/PKGBUILD b/PKGBUILD
index 2d84cae62128..fb1cfe6b53af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=htop
pkgname="${_pkgname}-vim"
-pkgver=3.2.1
+pkgver=3.2.2
pkgrel=1
pkgdesc='Interactive process viewer with a Vim keybindings patch'
arch=('x86_64')
@@ -19,8 +19,8 @@ options=('!emptydirs')
source=("https://github.com/htop-dev/htop/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
'vim-keybindings.patch'
)
-sha256sums=('b5ffac1949a8daaabcffa659c0964360b5008782aae4dfa7702d2323cfb4f438'
- 'dd0fbe1685d4e7966c18dcfa9946da436a1d198d071def5ff7c39df8126e9483')
+sha256sums=('3829c742a835a0426db41bb039d1b976420c21ec65e93b35cd9bfd2d57f44ac8'
+ '06eb3383e3643f0edcbf5c2b5a7ef8e261dd9f81a2435bd9a17f941583c44bd2')
prepare() {
cd "${_pkgname}-${pkgver}"
diff --git a/vim-keybindings.patch b/vim-keybindings.patch
index f34edd91832b..a30f551f2c6f 100644
--- a/vim-keybindings.patch
+++ b/vim-keybindings.patch
@@ -1,17 +1,17 @@
diff --git a/Action.c b/Action.c
-index b765248..50b32f5 100644
+index 81432f5..c2b3d70 100644
--- a/Action.c
+++ b/Action.c
-@@ -507,7 +507,7 @@ static const struct {
- const char* info;
+@@ -531,7 +531,7 @@ static const struct {
} helpLeft[] = {
+ { .key = " #: ", .roInactive = false, .info = "hide/show header meters" },
{ .key = " Tab: ", .roInactive = false, .info = "switch to next screen tab" },
- { .key = " Arrows: ", .roInactive = false, .info = "scroll process list" },
+ { .key = " hjkl: ", .roInactive = false, .info = "scroll process list" },
{ .key = " Digits: ", .roInactive = false, .info = "incremental PID search" },
{ .key = " F3 /: ", .roInactive = false, .info = "incremental name search" },
{ .key = " F4 \\: ", .roInactive = false, .info = "incremental name filtering" },
-@@ -535,7 +535,7 @@ static const struct {
+@@ -559,7 +559,7 @@ static const struct {
{ .key = " Space: ", .roInactive = false, .info = "tag process" },
{ .key = " c: ", .roInactive = false, .info = "tag process and its children" },
{ .key = " U: ", .roInactive = false, .info = "untag all processes" },
@@ -20,7 +20,7 @@ index b765248..50b32f5 100644
{ .key = " F7 ]: ", .roInactive = true, .info = "higher priority (root only)" },
{ .key = " F8 [: ", .roInactive = true, .info = "lower priority (+ nice)" },
#if (defined(HAVE_LIBHWLOC) || defined(HAVE_AFFINITY))
-@@ -543,12 +543,12 @@ static const struct {
+@@ -567,12 +567,12 @@ static const struct {
#endif
{ .key = " e: ", .roInactive = false, .info = "show process environment" },
{ .key = " i: ", .roInactive = true, .info = "set IO priority" },
@@ -36,14 +36,15 @@ index b765248..50b32f5 100644
{ .key = " F10 q: ", .roInactive = false, .info = "quit" },
{ .key = NULL, .info = NULL }
};
-@@ -747,12 +747,14 @@ void Action_setBindings(Htop_Action* keys) {
+@@ -772,6 +772,7 @@ void Action_setBindings(Htop_Action* keys) {
keys['H'] = actionToggleUserlandThreads;
keys['I'] = actionInvertSortOrder;
keys['K'] = actionToggleKernelThreads;
+ keys['L'] = actionLsof;
keys['M'] = actionSortByMemory;
keys['N'] = actionSortByPID;
- keys['P'] = actionSortByCPU;
+ keys['O'] = actionToggleRunningInContainer;
+@@ -779,6 +780,7 @@ void Action_setBindings(Htop_Action* keys) {
keys['S'] = actionSetup;
keys['T'] = actionSortByTime;
keys['U'] = actionUntagAll;
@@ -51,7 +52,7 @@ index b765248..50b32f5 100644
keys['Z'] = actionTogglePauseProcessUpdate;
keys['['] = actionLowerPriority;
keys['\014'] = actionRedraw; // Ctrl+L
-@@ -762,17 +764,15 @@ void Action_setBindings(Htop_Action* keys) {
+@@ -788,17 +790,15 @@ void Action_setBindings(Htop_Action* keys) {
keys['a'] = actionSetAffinity;
keys['c'] = actionTagAllChildren;
keys['e'] = actionShowEnvScreen;
@@ -89,7 +90,7 @@ index 6e905ce..e7253ac 100644
case EVENT_SET_SELECTED:
result = HANDLED;
diff --git a/MainPanel.c b/MainPanel.c
-index 44915df..4747788 100644
+index 89b4e7d..fba01fe 100644
--- a/MainPanel.c
+++ b/MainPanel.c
@@ -51,7 +51,7 @@ static const char* MainPanel_getValue(Panel* this, int i) {
@@ -113,7 +114,7 @@ index bd22acd..069d0b3 100644
+
#endif
diff --git a/Panel.c b/Panel.c
-index 4ea03f6..83a4acf 100644
+index d1bc6a7..da31429 100644
--- a/Panel.c
+++ b/Panel.c
@@ -358,6 +358,7 @@ bool Panel_onKey(Panel* this, int key) {
@@ -185,7 +186,7 @@ index 4ea03f6..83a4acf 100644
break;
diff --git a/ScreenManager.c b/ScreenManager.c
-index e4b04bd..d5d7ccd 100644
+index 55cacd2..f6b8f50 100644
--- a/ScreenManager.c
+++ b/ScreenManager.c
@@ -16,6 +16,7 @@ in the source distribution for its full text.
@@ -196,7 +197,7 @@ index e4b04bd..d5d7ccd 100644
#include "Macros.h"
#include "Object.h"
#include "Platform.h"
-@@ -294,14 +295,16 @@ void ScreenManager_run(ScreenManager* this, Panel** lastFocus, int* lastKey, con
+@@ -305,14 +306,16 @@ void ScreenManager_run(ScreenManager* this, Panel** lastFocus, int* lastKey, con
redraw = false;
continue;
}
@@ -219,7 +220,7 @@ index e4b04bd..d5d7ccd 100644
result = Panel_eventHandler(panelFocus, ch);
}
if (result & SYNTH_KEY) {
-@@ -335,7 +338,7 @@ void ScreenManager_run(ScreenManager* this, Panel** lastFocus, int* lastKey, con
+@@ -346,7 +349,7 @@ void ScreenManager_run(ScreenManager* this, Panel** lastFocus, int* lastKey, con
continue;
}
case KEY_LEFT:
@@ -228,7 +229,7 @@ index e4b04bd..d5d7ccd 100644
if (this->panelCount < 2) {
goto defaultHandler;
}
-@@ -356,7 +359,7 @@ tryLeft:
+@@ -367,7 +370,7 @@ tryLeft:
break;
case KEY_RIGHT:
@@ -238,47 +239,48 @@ index e4b04bd..d5d7ccd 100644
if (this->panelCount < 2) {
goto defaultHandler;
diff --git a/htop.1.in b/htop.1.in
-index c81c819..af5e0b6 100644
+index eefc37f..aeac630 100644
--- a/htop.1.in
+++ b/htop.1.in
-@@ -100,27 +100,29 @@ The following commands are supported while in
+@@ -100,27 +100,30 @@ The following commands are supported while in
Select the next / the previous screen tab to display.
You can enable showing the screen tab names in the Setup screen (F2).
.TP
-.B Up, Alt-k
-+.B Up, k
++.B Up, k (vim patch)
Select (highlight) the previous process in the process list. Scroll the list
if necessary.
.TP
-.B Down, Alt-j
-+.B Down, j
++.B Down, j (vim patch)
Select (highlight) the next process in the process list. Scroll the list if
necessary.
.TP
-.B Left, Alt-h
-+.B Left, h
++.B Left, h (vim patch)
Scroll the process list left.
.TP
-.B Right, Alt-l
-+.B Right, l
++.B Right, l (vim patch)
Scroll the process list right.
.TP
-.B PgUp, PgDn
-+.B PgUp, Ctrl-B, PgDn, Ctrl-F
++.B PgUp, Ctrl-B (vim patch), PgDn, Ctrl-F (vim patch)
Scroll the process list up or down one window.
.TP
-.B Home
-+.B Ctrl-U, Ctrl-D
++.B Ctrl-U (vim patch), Ctrl-D (vim patch)
+Scroll the process list up or down half a window.
-+.B Home, g
++.TP
++.B Home, g (vim patch)
Scroll to the top of the process list and select the first process.
.TP
-.B End
-+.B End, G
++.B End, G (vim patch)
Scroll to the bottom of the process list and select the last process.
.TP
.B Ctrl-A, ^
-@@ -155,7 +157,7 @@ will display the list of file descriptors opened by the process.
+@@ -155,7 +158,7 @@ will display the list of file descriptors opened by the process.
Display the command line of the selected process in a separate screen, wrapped
onto multiple lines as needed.
.TP
@@ -287,30 +289,30 @@ index c81c819..af5e0b6 100644
Display the active file locks of the selected process in a separate screen.
.TP
.B F1, h, ?
-@@ -189,7 +191,7 @@ between them as a tree. Toggling the key will switch between tree and
+@@ -189,7 +192,7 @@ between them as a tree. Toggling the key will switch between tree and
your previously selected sort view. Selecting a sort view will exit
tree view.
.TP
-.B F6, <, >
-+.B F6, <, >, o
++.B F6, <, >, o (vim patch)
Selects a field for sorting, also accessible through < and >.
The current sort field is indicated by a highlight in the header.
.TP
-@@ -207,7 +209,7 @@ This can only be done by the superuser.
+@@ -207,7 +210,7 @@ This can only be done by the superuser.
.B Shift-F8, {
Decrease the selected process's autogroup priority (add to autogroup 'nice' value)
.TP
-.B F9, k
-+.B F9, x
++.B F9, x (vim patch)
"Kill" process: sends a signal which is selected in a menu, to one or a group
of processes. If processes were tagged, sends the signal to all tagged processes.
If none is tagged, sends to the currently selected process.
-@@ -219,7 +221,7 @@ Quit
+@@ -219,7 +222,7 @@ Quit
Invert the sort order: if sort order is increasing, switch to decreasing, and
vice-versa.
.TP
-.B +, \-, *
-+.B +, \-, *, o
++.B +, \-, *, o (vim patch)
When in tree view mode, expand or collapse subtree. When a subtree is collapsed
a "+" sign shows to the left of the process name.
Pressing "*" will expand or collapse all children of PIDs without parents, so