summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoffeinFlummi2015-09-04 21:27:29 +0200
committerKoffeinFlummi2015-09-04 21:27:29 +0200
commit4c18670988b5a3411274c9926fe7f58dc470943c (patch)
tree17946168fbc394f415d2fab9ac729c77bcb6b1ce
parent37df03d03457b9eacbdb947d22a96225f370e060 (diff)
downloadaur-4c18670988b5a3411274c9926fe7f58dc470943c.tar.gz
Fix patch (again), bumb version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--vim-keybindings.patch20
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b34153bcaae0..e99b8adfe7eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = htop-vim-git
pkgdesc = Interactive text-mode process viewer. Patched for vim keybindings
- pkgver = 584.8f07868
+ pkgver = 607.2df36ee
pkgrel = 1
url = https://github.com/hishamhm/htop
arch = i686
@@ -18,7 +18,7 @@ pkgbase = htop-vim-git
source = git+https://github.com/hishamhm/htop.git
source = vim-keybindings.patch
sha256sums = SKIP
- sha256sums = d58771be77157419f539a3cd5271aa6adeba1d86a90053e7e63d035cb654cb30
+ sha256sums = f89f25cfd0430595e6a36f4e9c5677ff78dc63e93dc104a8a238a05a8f9e3ca9
pkgname = htop-vim-git
diff --git a/PKGBUILD b/PKGBUILD
index b37b2f80297b..b86411445e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=htop
pkgname=${_pkgname}-vim-git
-pkgver=584.8f07868
+pkgver=607.2df36ee
pkgrel=1
pkgdesc="Interactive text-mode process viewer. Patched for vim keybindings"
url="https://github.com/hishamhm/${_pkgname}"
@@ -18,7 +18,7 @@ options=('!emptydirs')
source=("git+${url}.git"
'vim-keybindings.patch')
sha256sums=('SKIP'
- 'd58771be77157419f539a3cd5271aa6adeba1d86a90053e7e63d035cb654cb30')
+ 'f89f25cfd0430595e6a36f4e9c5677ff78dc63e93dc104a8a238a05a8f9e3ca9')
pkgver() {
cd "${srcdir}/${_pkgname}"
diff --git a/vim-keybindings.patch b/vim-keybindings.patch
index e535ffebac70..994cee1b367f 100644
--- a/vim-keybindings.patch
+++ b/vim-keybindings.patch
@@ -86,7 +86,7 @@ index 2e91a3c..7a8b2bd 100644
super->needsRedraw = true;
return HANDLED;
diff --git a/Panel.c b/Panel.c
-index f421a0d..1b40bb1 100644
+index 6540970..d213855 100644
--- a/Panel.c
+++ b/Panel.c
@@ -86,6 +86,8 @@ struct Panel_ {
@@ -98,7 +98,7 @@ index f421a0d..1b40bb1 100644
PanelClass Panel_class = {
.super = {
-@@ -369,14 +371,16 @@ void Panel_draw(Panel* this, bool focus) {
+@@ -372,14 +374,16 @@ void Panel_draw(Panel* this, bool focus) {
bool Panel_onKey(Panel* this, int key) {
assert (this != NULL);
@@ -116,7 +116,7 @@ index f421a0d..1b40bb1 100644
case KEY_CTRLP:
this->selected--;
break;
-@@ -391,23 +395,33 @@ bool Panel_onKey(Panel* this, int key) {
+@@ -394,23 +398,33 @@ bool Panel_onKey(Panel* this, int key) {
break;
#endif
case KEY_LEFT:
@@ -152,7 +152,7 @@ index f421a0d..1b40bb1 100644
this->selected += (this->h - 1);
this->scrollV += (this->h - 1);
this->needsRedraw = true;
-@@ -428,9 +442,11 @@ bool Panel_onKey(Panel* this, int key) {
+@@ -431,9 +445,11 @@ bool Panel_onKey(Panel* this, int key) {
break;
}
case KEY_HOME:
@@ -178,12 +178,12 @@ index 6789770..22a0f3f 100644
extern PanelClass Panel_class;
diff --git a/README b/README
-index f713e1c..48c164b 100644
+index 3bc17a4..877cf20 100644
--- a/README
+++ b/README
-@@ -28,6 +28,44 @@ This software has evolved considerably during the last years,
- and is reasonably complete, but there is still room for
- improvement. Read the TODO file to see what's known to be missing.
+@@ -16,6 +16,44 @@ but we also have code for running under FreeBSD and Mac OS X
+ This software has evolved considerably over the years,
+ and is reasonably complete, but there is always room for improvement.
+Vim keybindings
+----------------
@@ -223,8 +223,8 @@ index f713e1c..48c164b 100644
+* 'l' can no longer be used to list open files, being replaced with 'L'
+
+
- Comparison between 'htop' and 'top'
- -----------------------------------
+ Comparison between 'htop' and classic 'top'
+ -------------------------------------------
diff --git a/ScreenManager.c b/ScreenManager.c
index df7431f..68d3953 100644