summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Ryan2015-08-25 12:55:42 -0400
committerJonathan Ryan2015-08-25 12:55:42 -0400
commitd11acefdfd292fcf75d736a97177702a49c0d5da (patch)
treeff63ca089fe991e3331b00ea4d24fb4d54011c24
downloadaur-d11acefdfd292fcf75d736a97177702a49c0d5da.tar.gz
Initial import.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--htpdate.service10
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5330a121ea2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = htpdate
+ pkgdesc = A client for time synchronisation
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://www.vervest.org/htp/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ source = http://www.vervest.org/htp/archive/c/htpdate-1.1.1.tar.xz
+ source = htpdate.service
+ md5sums = c612f63282e3f23b709f37a5c81d4739
+ md5sums = b419153625904d9a5544e585f69c66c5
+
+pkgname = htpdate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ff331e214a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jonathan Ryan <jryan@curious-computing.com>
+# Contributor: Hussam Al-Tayeb <hussam@visp.net.lb>
+pkgname=htpdate
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="A client for time synchronisation"
+arch=(i686 x86_64)
+url="http://www.vervest.org/htp/"
+license=(GPL2)
+depends=('glibc')
+source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz" "htpdate.service")
+md5sums=('c612f63282e3f23b709f37a5c81d4739'
+ 'b419153625904d9a5544e585f69c66c5')
+build() {
+ cd ${pkgname}-${pkgver}
+ make
+}
+package() {
+ install -D -m 644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
+ cd ${pkgname}-${pkgver}
+ install -D -m 755 htpdate ${pkgdir}/usr/bin/htpdate
+ install -D -m 644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
+}
+
diff --git a/htpdate.service b/htpdate.service
new file mode 100644
index 000000000000..831f411cc4da
--- /dev/null
+++ b/htpdate.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Htpdate Daemon
+
+[Service]
+Type=forking
+PIDFile=/run/htpdate.pid
+ExecStart=/usr/bin/htpdate -D -s -i /run/htpdate.pid www.linux.org www.freebsd.org
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file