summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-08-11 12:30:16 +0100
committerAlexandros Theodotou2019-08-11 12:30:16 +0100
commitccba4ae25b22650aafef71ed932b880cef44c54e (patch)
tree79844d032bb0330e4ea7142550aec10a9d8210f9
downloadaur-ccba4ae25b22650aafef71ed932b880cef44c54e.tar.gz
add sinsy voice bank
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25ff3da2dcac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hts-nit-song070-f001
+ pkgdesc = HTS voice trained by using the Nitech Japanese Speech Database NIT SONG070 F001
+ pkgver = 0.90
+ pkgrel = 1
+ url = http://www.sinsy.jp/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = custom
+ source = https://downloads.sourceforge.net/project/sinsy/HTS%20voice/hts_voice_nitech_jp_song070_f001-0.90/hts_voice_nitech_jp_song070_f001-0.90.tar.gz
+ md5sums = 018cce3ccb1f7110286863420b116d5b
+ sha1sums = 70a00c87f85a4a6cd7f14c329cae63388c9b8027
+
+pkgname = hts-nit-song070-f001
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..90c4ad5bb35e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz*
+*.tar.gz*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de0d3127ea21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexandros Theodotou <alex@zrythm.org>
+_tarball=hts_voice_nitech_jp_song070_f001
+pkgname=hts-nit-song070-f001
+pkgver=0.90
+pkgrel=1
+pkgdesc="HTS voice trained by using the Nitech Japanese Speech Database NIT SONG070 F001"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://www.sinsy.jp/"
+license=('custom')
+depends=()
+source=(https://downloads.sourceforge.net/project/sinsy/HTS%20voice/$_tarball-$pkgver/$_tarball-$pkgver.tar.gz)
+md5sums=('018cce3ccb1f7110286863420b116d5b')
+sha1sums=('70a00c87f85a4a6cd7f14c329cae63388c9b8027')
+
+package()
+{
+ cd "$srcdir/$_tarball-$pkgver"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -D -m644 nitech_jp_song070_f001.htsvoice "${pkgdir}/usr/share/${pkgname}/"
+ install -D -m644 SAMPLE.xml "${pkgdir}/usr/share/${pkgname}/"
+}
+