summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-06-13 11:57:27 +0200
committerChristian Krause2015-06-13 11:57:27 +0200
commit17038aefe32b6b71036ec2ff40b3657b071a38dd (patch)
treea29d52030abb76757d0f2a1df736ab1300dc8e43
downloadaur-17038aefe32b6b71036ec2ff40b3657b071a38dd.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0896db2b64c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = htslib
+ pkgdesc = library for high-throughput sequencing data formats
+ pkgver = 1.2.1
+ pkgrel = 2
+ url = https://github.com/samtools/htslib
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = zlib
+ provides = tabix
+ conflicts = tabix
+ replaces = tabix
+ source = htslib-1.2.1.tar.gz::https://github.com/samtools/htslib/archive/1.2.1.tar.gz
+ md5sums = 81f5f1aa17a188a6b6250ca67d83384d
+
+pkgname = htslib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d2ba1cd8137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=htslib
+pkgver=1.2.1
+pkgrel=2
+pkgdesc="library for high-throughput sequencing data formats"
+arch=('i686' 'x86_64')
+url="https://github.com/samtools/htslib"
+license=('custom')
+depends=('zlib')
+provides=('tabix')
+replaces=('tabix')
+conflicts=('tabix')
+source=($pkgname-$pkgver.tar.gz::https://github.com/samtools/htslib/archive/$pkgver.tar.gz)
+md5sums=('81f5f1aa17a188a6b6250ca67d83384d')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ autoreconf -i
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
+
+ make
+}
+
+check() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make check
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make DESTDIR=$pkgdir install
+
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ # htslib shared library comes installed as 0644
+ chmod +x $pkgdir/usr/lib/libhts.so.*.*.*
+}