summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-09-01 14:28:32 +0800
committerChocobo12020-09-01 14:34:18 +0800
commit9f8601a199faa77a2ce1e552f86979e6c77ed015 (patch)
tree76a88409f021a2f26018e1414ea1d47bcceb2f05
downloadaur-9f8601a199faa77a2ce1e552f86979e6c77ed015.tar.gz
newpkg: htslib-git 1.10.2.r134.ge9447f86-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..327e4b0ada73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = htslib-git
+ pkgdesc = C library for high-throughput sequencing data formats
+ pkgver = 1.10.2.r134.ge9447f86
+ pkgrel = 1
+ url = https://github.com/samtools/htslib
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = glibc
+ depends = bzip2
+ depends = curl
+ provides = htslib
+ conflicts = htslib
+ options = staticlibs
+ source = git+https://github.com/samtools/htslib.git
+ sha256sums = SKIP
+
+pkgname = htslib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0e767734688
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=htslib-git
+pkgver=1.10.2.r134.ge9447f86
+pkgrel=1
+pkgdesc="C library for high-throughput sequencing data formats"
+arch=('i686' 'x86_64')
+url="https://github.com/samtools/htslib"
+license=('custom')
+depends=('glibc' 'bzip2' 'curl')
+makedepends=('git')
+provides=('htslib')
+conflicts=('htslib')
+options=('staticlibs')
+source=("git+https://github.com/samtools/htslib.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "htslib"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "htslib"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr" \
+ --enable-plugins \
+ --with-plugin-dir="/usr/lib/htslib/plugins"
+ make
+}
+
+check() {
+ cd "htslib"
+
+ #make check
+}
+
+package() {
+ cd "htslib"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/htslib"
+}