summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxgjmibzr2023-01-31 11:25:22 -0700
committerxgjmibzr2023-01-31 11:25:22 -0700
commit12ae3489ebc34cabdfd20f230cf4f52c8340a03a (patch)
tree8c99d7377f47d5e0b03ed578e864f930a6bb8a8f
parentf6d0e67e8668730983be40ae1ae899b39342b74f (diff)
downloadaur-12ae3489ebc34cabdfd20f230cf4f52c8340a03a.tar.gz
Enable httm helper scripts ounce (ZFS only), bowie, and nicotine.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6030ead1bd9..015d7e4fe40b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = httm-git
pkgdesc = Prints the size, date and locations of available unique versions (deduplicated by modify time and size) of files residing on ZFS or BTRFS snapshots.
- pkgver = r1978.f535197
+ pkgver = r2167.8bd326f
pkgrel = 1
url = https://github.com/kimono-koans/httm
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a92f10f3f0a5..b5058e458a4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: xgjmibzr <xgjmibzr@gmail.com>
pkgname=httm-git
-pkgver=r1978.f535197
+pkgver=r2167.8bd326f
pkgrel=1
pkgdesc="Prints the size, date and locations of available unique versions (deduplicated by modify time and size) of files residing on ZFS or BTRFS snapshots."
arch=('x86_64')
@@ -32,11 +32,23 @@ build(){
}
package(){
- echo "Install exec"
# install executable
install -Dm755 "${srcdir}/bin/httm" "${pkgdir}/usr/bin/httm"
- echo "Install man"
+ # install helper scripts
+ install -Dm755 "${srcdir}/httm/scripts/bowie.bash" "${pkgdir}/usr/bin/bowie"
+ install -Dm755 "${srcdir}/httm/scripts/nicotine.bash" "${pkgdir}/usr/bin/nicotine"
+
+ [[ -z "$(
+ command -v zfs
+ exit 0
+ )" ]] || install -Dm755 "${srcdir}/httm/scripts/ounce.bash" "${pkgdir}/usr/bin/ounce"
+
+ [[ -n "$(
+ command -v zfs
+ exit 0
+ )" ]] || echo "zfs not in path, helper script 'ounce' not installed"
+
# install man page
install -Dm644 "${srcdir}/httm/httm.1" "${pkgdir}/usr/share/man/man1/httm.1"