summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxgjmibzr2022-12-13 20:35:28 -0700
committerxgjmibzr2022-12-13 20:35:28 -0700
commitf6d0e67e8668730983be40ae1ae899b39342b74f (patch)
tree7fee4d4c84b4df605f2cb25e1ed399898b459ee8
downloadaur-f6d0e67e8668730983be40ae1ae899b39342b74f.tar.gz
0.18.1 - initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD48
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6030ead1bd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = httm-git
+ pkgdesc = Prints the size, date and locations of available unique versions (deduplicated by modify time and size) of files residing on ZFS or BTRFS snapshots.
+ pkgver = r1978.f535197
+ pkgrel = 1
+ url = https://github.com/kimono-koans/httm
+ arch = x86_64
+ license = MPL-2.0
+ makedepends = cargo
+ makedepends = git
+ depends = gcc-libs
+ optdepends = btrfs-progs: BTRFS support
+ optdepends = zfs-utils: ZFS support
+ provides = httm
+ conflicts = httm
+ conflicts = httm-bin
+ options = !strip
+ options = !emptydirs
+ source = git+https://github.com/kimono-koans/httm.git
+ sha512sums = SKIP
+
+pkgname = httm-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fd190ec95f93
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Everything
+*
+
+# Except
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a92f10f3f0a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: xgjmibzr <xgjmibzr@gmail.com>
+
+pkgname=httm-git
+pkgver=r1978.f535197
+pkgrel=1
+pkgdesc="Prints the size, date and locations of available unique versions (deduplicated by modify time and size) of files residing on ZFS or BTRFS snapshots."
+arch=('x86_64')
+url="https://github.com/kimono-koans/httm"
+license=('MPL-2.0')
+provides=('httm')
+conflicts=('httm' 'httm-bin')
+options=('!strip' '!emptydirs')
+depends=('gcc-libs')
+optdepends=('btrfs-progs: BTRFS support'
+ 'zfs-utils: ZFS support')
+makedepends=('cargo' 'git')
+source=("git+https://github.com/kimono-koans/httm.git")
+sha512sums=('SKIP')
+
+pkgver()
+{
+ cd "$srcdir/httm"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build(){
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ # use cargo to build from a tagged release
+ cd "${srcdir}/httm"
+ cargo install --root ${srcdir} --git $url
+}
+
+package(){
+ echo "Install exec"
+ # install executable
+ install -Dm755 "${srcdir}/bin/httm" "${pkgdir}/usr/bin/httm"
+
+ echo "Install man"
+ # install man page
+ install -Dm644 "${srcdir}/httm/httm.1" "${pkgdir}/usr/share/man/man1/httm.1"
+
+ # install README.md
+ install -Dm644 "${srcdir}/httm/README.md" "${pkgdir}/usr/share/doc/httm/README.md"
+
+ # install LICENSE
+ install -Dm644 "${srcdir}/httm/LICENSE" "${pkgdir}/usr/share/licenses/httm/LICENSE"
+}