summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn Rose2017-11-04 18:29:30 -0230
committerShawn Rose2017-11-04 18:29:30 -0230
commit7a239a6b5f44326010df80e7c4a25cc1fe4a51f0 (patch)
tree95147b9d5ac3447b3cb18f022559f90281a8e850
parent9c96663ac12678a8ad07da5d5d83be5989f3843d (diff)
downloadaur-http-parser-git.tar.gz
version 2.7.1.r13.g5c2d339-1
- Updated to use 'make install' - Added check function - Added armv7h support - Now specifically points to nodejs repository
-rw-r--r--.AURINFO7
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
3 files changed, 20 insertions, 18 deletions
diff --git a/.AURINFO b/.AURINFO
index 77bdecd5fd41..0fccaa173c6e 100644
--- a/.AURINFO
+++ b/.AURINFO
@@ -1,16 +1,17 @@
pkgbase = http-parser-git
pkgdesc = Parser for HTTP Request/Response written in C
- pkgver = 2.3.r4.g158dd3b
+ pkgver = 2.7.1.r13.g5c2d339
pkgrel = 1
- url = https://github.com/joyent/http-parser
+ url = https://github.com/nodejs/http-parser
arch = i686
arch = x86_64
+ arch = armv7h
license = MIT
makedepends = git
depends = glibc
provides = http-parser
conflicts = http-parser
- source = http-parser-git::git+https://github.com/joyent/http-parser.git
+ source = http-parser-git::git+https://github.com/nodejs/http-parser.git
pkgname = http-parser-git
diff --git a/.SRCINFO b/.SRCINFO
index e1212257bf0e..fe198f6d7ef1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = http-parser-git
pkgdesc = Parser for HTTP Request/Response written in C
- pkgver = 2.7.0.r1.gf2c26ee
+ pkgver = 2.7.1.r13.g5c2d339
pkgrel = 1
- url = https://github.com/joyent/http-parser
+ url = https://github.com/nodejs/http-parser
arch = i686
arch = x86_64
+ arch = armv7h
license = MIT
makedepends = git
depends = glibc
provides = http-parser
conflicts = http-parser
- source = http-parser-git::git+https://github.com/joyent/http-parser.git
+ source = http-parser-git::git+https://github.com/nodejs/http-parser.git
md5sums = SKIP
pkgname = http-parser-git
diff --git a/PKGBUILD b/PKGBUILD
index 2b970225298a..ec0a823de770 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=http-parser-git
-pkgver=2.7.0.r1.gf2c26ee
+pkgver=2.7.1.r13.g5c2d339
pkgrel=1
pkgdesc="Parser for HTTP Request/Response written in C"
-arch=('i686' 'x86_64')
-url="https://github.com/joyent/http-parser"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/nodejs/http-parser"
license=('MIT')
depends=('glibc')
makedepends=('git')
conflicts=('http-parser')
provides=('http-parser')
-source=("$pkgname::git+https://github.com/joyent/http-parser.git")
-md5sums=('SKIP')
+source=("$pkgname::git+https://github.com/nodejs/http-parser.git")
+sha256sums=('SKIP')
pkgver() {
cd $pkgname
@@ -24,9 +24,14 @@ build() {
make library
}
-package() {
+check() {
cd $pkgname
+ local CPPFLAGS="${CPPFLAGS/-D_FORTIFY_SOURCE=2/}"
+ make test
+}
+package() {
+ cd $pkgname
install -Dm644 LICENSE-MIT \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
install -Dm644 AUTHORS \
@@ -34,10 +39,5 @@ package() {
install -Dm644 README.md \
"${pkgdir}/usr/share/doc/${pkgname}/README.md"
- install -Dm644 http_parser.h "${pkgdir}/usr/include/http_parser.h"
- install -Dm644 libhttp_parser.so.2.7.0 "${pkgdir}/usr/lib/libhttp_parser.so.2.7.0"
-
- ln -sf libhttp_parser.so.2.7.0 "${pkgdir}/usr/lib/libhttp_parser.so.2.7"
- ln -sf libhttp_parser.so.2.7.0 "${pkgdir}/usr/lib/libhttp_parser.so.2"
- ln -sf libhttp_parser.so.2.7.0 "${pkgdir}/usr/lib/libhttp_parser.so"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
}