summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-03-30 05:20:45 -0600
committerBrian Bidulock2015-06-10 06:12:35 -0600
commitf5e6d5fb9bec6d760904cb1751cef2027594c1c8 (patch)
treed80777c5ed5b445b491dc3dc45db3643cc65fa08
parent94ba43dab2fe51751537884dd4cc97e815ce0efb (diff)
downloadaur-f5e6d5fb9bec6d760904cb1751cef2027594c1c8.tar.gz
version 2.3.r2.gd19e129-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2b123f5686e..854fce7ff5f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = http-parser-git
pkgdesc = Parser for HTTP Request/Response written in C
- pkgver = 2.5.r3.g39ff097
+ pkgver = 2.3.r2.gd19e129
pkgrel = 1
url = https://github.com/joyent/http-parser
arch = i686
@@ -9,7 +9,6 @@ pkgbase = http-parser-git
makedepends = git
depends = glibc
provides = http-parser
- conflicts = http-parser
source = http-parser-git::git+https://github.com/joyent/http-parser.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 47678139e739..0041108c7a96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=http-parser-git
-pkgver=2.5.r3.g39ff097
+pkgver=2.3.r2.gd19e129
pkgrel=1
pkgdesc="Parser for HTTP Request/Response written in C"
arch=('i686' 'x86_64')
@@ -9,7 +9,6 @@ url="https://github.com/joyent/http-parser"
license=('MIT')
depends=('glibc')
makedepends=('git')
-conflicts=('http-parser')
provides=('http-parser')
source=("$pkgname::git+https://github.com/joyent/http-parser.git")
md5sums=('SKIP')
@@ -30,14 +29,15 @@ package() {
install -Dm644 LICENSE-MIT \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
install -Dm644 AUTHORS \
- "${pkgdir}/usr/share/doc/${pkgname}/AUTHORS"
+ "${pkgdir}/usr/share/doc/${_pkgname}/AUTHORS"
+ install -Dm644 CONTRIBUTIONS \
+ "${pkgdir}/usr/share/doc/${_pkgname}/CONTRIBUTIONS"
install -Dm644 README.md \
- "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
install -Dm644 http_parser.h "${pkgdir}/usr/include/http_parser.h"
- install -Dm644 libhttp_parser.so.2.5.0 "${pkgdir}/usr/lib/libhttp_parser.so.2.5.0"
+ install -Dm644 libhttp_parser.so.2.3 "${pkgdir}/usr/lib/libhttp_parser.so.2.3"
- ln -sf libhttp_parser.so.2.5.0 "${pkgdir}/usr/lib/libhttp_parser.so.2.5"
- ln -sf libhttp_parser.so.2.5.0 "${pkgdir}/usr/lib/libhttp_parser.so.2"
- ln -sf libhttp_parser.so.2.5.0 "${pkgdir}/usr/lib/libhttp_parser.so"
+ ln -sf libhttp_parser.so.2.3 "${pkgdir}/usr/lib/libhttp_parser.so.2"
+ ln -sf libhttp_parser.so.2.3 "${pkgdir}/usr/lib/libhttp_parser.so"
}