summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMicah Halter2019-12-01 10:04:42 -0500
committerMicah Halter2019-12-01 10:04:42 -0500
commitb4d872d20f75d7541f898a2ddd4d33d7728d55df (patch)
tree4023678d73152b24f025a8a3bc6d49c835ccd496
parent0559d2653ec3aac99c14659d9fcb8af90512c8ff (diff)
downloadaur-b4d872d20f75d7541f898a2ddd4d33d7728d55df.tar.gz
Updated package
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c69d61f5c91e..d7a916ddbe7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Jan 4 12:53:47 UTC 2019
pkgbase = http-prompt
pkgdesc = An interactive HTTP command-line client
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/eliangcs/http-prompt
arch = any
license = MIT
@@ -16,6 +14,7 @@ pkgbase = http-prompt
depends = python-six
depends = python-parsimonious
depends = python-pip
+ depends = python-pyaml
source = https://files.pythonhosted.org/packages/source/h/http-prompt/http-prompt-1.0.0.tar.gz
md5sums = aee6b913be3190f66f8765281ce3d8f0
diff --git a/PKGBUILD b/PKGBUILD
index db22342c281d..d09a301d6fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
+# Maintainer: mehalter <micah at mehalter.com>
# Maintainer: wenLiangcan <boxeed at gmail dot com>
# Maintainer: vinipsmaker <vini.ipsmaker@gmail.com>
-pkgbase=('http-prompt')
-pkgname=('http-prompt')
+pkgbase=http-prompt
+pkgname=http-prompt
_module='http-prompt'
pkgver='1.0.0'
-pkgrel=1
+pkgrel=2
pkgdesc="An interactive HTTP command-line client"
url="https://github.com/eliangcs/http-prompt"
depends=('python'
@@ -15,7 +16,8 @@ depends=('python'
'python-pygments'
'python-six'
'python-parsimonious'
- 'python-pip')
+ 'python-pip'
+ 'python-pyaml')
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
@@ -31,5 +33,5 @@ package() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
sed -e 's/prompt-toolkit/prompt-toolkit1/g' -i \
- "${pkgdir}/usr/lib/python3.7/site-packages/http_prompt-1.0.0-py3.7.egg-info/requires.txt"
+ "${pkgdir}/usr/lib/python3.8/site-packages/http_prompt-1.0.0-py3.8.egg-info/requires.txt"
}