summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2016-05-19 21:30:38 +0800
committerwenLiangcan2016-05-19 21:30:38 +0800
commite929d743413192f965b2f91b49333fac2ea2ccd8 (patch)
treee074701e0f6abd13bb9f4d8bd94f072ceafea488
downloadaur-e929d743413192f965b2f91b49333fac2ea2ccd8.tar.gz
http-prompt 0.1.1-1.
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD21
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b0f0ff385a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu May 19 13:30:11 UTC 2016
+pkgbase = http-prompt
+ pkgdesc = An interactive HTTP command-line client
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/eliangcs/http-prompt
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = httpie
+ depends = python-prompt_toolkit
+ depends = python-pygments
+ depends = python-six
+ depends = python-parsimonious
+ depends = python-pip
+ source = https://pypi.python.org/packages/2c/67/8ba4088f8f45cd1d431a11149480f7780207692c82e013a518e388d36590/http-prompt-0.1.1.tar.gz
+ md5sums = f84290db4dde3de7f8d47ee4fa9431bf
+
+pkgname = http-prompt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..672880cfb03e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+### https://raw.github.com/github/gitignore/b27b46b656d026ac295b3a47cf43e8af192472e2/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac1ba0572982
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+pkgbase=('http-prompt')
+pkgname=('http-prompt')
+_module='http-prompt'
+pkgver='0.1.1'
+pkgrel=1
+pkgdesc="An interactive HTTP command-line client"
+url="https://github.com/eliangcs/http-prompt"
+depends=('python' 'python-click' 'httpie' 'python-prompt_toolkit' 'python-pygments' 'python-six' 'python-parsimonious' 'python-pip')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/2c/67/8ba4088f8f45cd1d431a11149480f7780207692c82e013a518e388d36590/http-prompt-${pkgver}.tar.gz")
+md5sums=('f84290db4dde3de7f8d47ee4fa9431bf')
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+