summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Parente Lima2021-06-24 18:31:18 -0300
committerHugo Parente Lima2021-06-24 18:31:18 -0300
commitcccad84abd572362cb8d8c039921d3b8ee9748e7 (patch)
treed8cfbed50731621826b7c60c87f2cfe19c8a22b7
downloadaur-cccad84abd572362cb8d8c039921d3b8ee9748e7.tar.gz
Release v0.1.0.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
-rwxr-xr-xupdate_pkg16
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a26b33218dc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = http-status-code-manpages
+ pkgdesc = Man pages for HTTP status codes
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/hugopl/http-status-code-manpages
+ arch = any
+ license = WTFPL
+ makedepends = ruby
+ makedepends = make
+ depends = man-db
+ source = http-status-code-manpages-0.1.0.tar.gz::https://github.com/hugopl/http-status-code-manpages/archive/v0.1.0.tar.gz
+ sha256sums = 46c54ba1eb1a3d4e67508d75ebade54c6b888802621bee300b55ea486f98576f
+
+pkgname = http-status-code-manpages
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..06b611475ccf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+*.tar.gz
+*.tar.xz
+*.zst
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7997c249d4ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hugo Parente Lima <hugo.pl@gmail.com>
+pkgname=http-status-code-manpages
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Man pages for HTTP status codes"
+url="https://github.com/hugopl/http-status-code-manpages"
+license=('WTFPL')
+arch=('any')
+depends=("man-db")
+makedepends=("ruby" "make")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/hugopl/http-status-code-manpages/archive/v${pkgver}.tar.gz")
+sha256sums=('46c54ba1eb1a3d4e67508d75ebade54c6b888802621bee300b55ea486f98576f')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/update_pkg b/update_pkg
new file mode 100755
index 000000000000..0f745d58cb1d
--- /dev/null
+++ b/update_pkg
@@ -0,0 +1,16 @@
+#!/usr/bin/env ruby
+
+new_sha = `makepkg -g`
+pkgbuild = File.readlines("PKGBUILD").map do |line|
+ if line =~ /\A\s*sha256sums/
+ new_sha
+ else
+ line
+ end
+end.join
+
+File.write("PKGBUILD", pkgbuild)
+system("makepkg --printsrcinfo > .SRCINFO")
+# puts new_sha
+puts "done!"
+