summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOwen Trigueros2020-07-10 07:46:37 +0200
committerOwen Trigueros2020-07-10 07:46:37 +0200
commit18c3ce1cf637dffa1a541cc34a3c02a69d3657c2 (patch)
treeca2d178e2be2b69c4ec2d66b36bc62d2396368fa
parent6becb218809f8a63ce7e07377a7354a91ef741e1 (diff)
downloadaur-18c3ce1cf637dffa1a541cc34a3c02a69d3657c2.tar.gz
Remove makedepends, replace sed with prefix
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b43d80e45c9c..596b8685ab64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,10 @@
pkgbase = httpdirfs
pkgdesc = A filesystem which allows you to mount HTTP directory listings
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fangfufu/httpdirfs
arch = any
license = GPL
- makedepends = gumbo-parser
- makedepends = fuse2
- makedepends = openssl
depends = gumbo-parser
depends = fuse2
depends = openssl
diff --git a/PKGBUILD b/PKGBUILD
index e929448039e7..0ce5009de00b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,19 @@
pkgname=httpdirfs
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A filesystem which allows you to mount HTTP directory listings"
arch=('any')
url="https://github.com/fangfufu/httpdirfs"
license=('GPL')
depends=('gumbo-parser' 'fuse2' 'openssl')
-makedepends=('gumbo-parser' 'fuse2' 'openssl')
source=("https://github.com/fangfufu/$pkgname/archive/$pkgver.tar.gz")
md5sums=("5c9c31c39217da0a9ff44b4cae5704eb")
prepare() {
- cd "$pkgname-$pkgver"
-
- # Replace /usr/local prefix with /usr
- sed -i 's/^prefix ?= \/usr\/local/prefix ?= \/usr/' Makefile
+ cd "$pkgname-$pkgver"
}
+
build() {
cd "$pkgname-$pkgver"
make
@@ -25,5 +22,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ make prefix=/usr DESTDIR="$pkgdir" install
}