summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Luttringer2017-03-05 14:25:32 +0100
committerSébastien Luttringer2017-03-05 14:25:32 +0100
commitdbd71541c1e7a78e36ea7481759a31b6f7deac2c (patch)
treea7163fdb064cb6e02ba9a78fbbae7756d8eb7772
downloadaur-dbd71541c1e7a78e36ea7481759a31b6f7deac2c.tar.gz
Initial commit
moved from community
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
-rw-r--r--use-SSLv23_client_method.patch13
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5eb3737c1dc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Mar 5 13:25:32 UTC 2017
+pkgbase = httperf
+ pkgdesc = A tool for measuring web server performance.
+ pkgver = 0.9.0
+ pkgrel = 8
+ url = http://code.google.com/p/httperf
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = openssl
+ source = http://httperf.googlecode.com/files/httperf-0.9.0.tar.gz
+ source = use-SSLv23_client_method.patch
+ md5sums = 2968c36b9ecf3d98fc1f2c1c9c0d9341
+ md5sums = 4b7cd4bd707c322f73333e34f0302b76
+
+pkgname = httperf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26cd6f7ed6ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id: PKGBUILD 207393 2017-01-14 18:17:11Z seblu $
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Essien Ita Essien <me@essienitaessien.com>
+# Contributor: Peter Baldwin <bald_pete@hotmail.com>
+
+pkgname=httperf
+pkgver=0.9.0
+pkgrel=8
+pkgdesc='A tool for measuring web server performance.'
+arch=('i686' 'x86_64')
+license=('GPL2')
+url='http://code.google.com/p/httperf'
+depends=('openssl')
+source=("http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+ 'use-SSLv23_client_method.patch')
+md5sums=('2968c36b9ecf3d98fc1f2c1c9c0d9341'
+ '4b7cd4bd707c322f73333e34f0302b76')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/use-SSLv23_client_method.patch b/use-SSLv23_client_method.patch
new file mode 100644
index 000000000000..d95c0a16bbe8
--- /dev/null
+++ b/use-SSLv23_client_method.patch
@@ -0,0 +1,13 @@
+diff -uprb httperf-0.9.0.orig/src/httperf.c httperf-0.9.0/src/httperf.c
+--- httperf-0.9.0.orig/src/httperf.c 2007-04-07 10:01:56.000000000 +0300
++++ httperf-0.9.0/src/httperf.c 2016-03-02 21:09:57.376029451 +0200
+@@ -808,7 +808,8 @@ main (int argc, char **argv)
+ SSLeay_add_ssl_algorithms ();
+
+ /* for some strange reason, SSLv23_client_method () doesn't work here */
+- ssl_ctx = SSL_CTX_new (SSLv3_client_method ());
++ /* hopefully the above comment is a lie */
++ ssl_ctx = SSL_CTX_new (SSLv23_client_method ());
+ if (!ssl_ctx)
+ {
+ ERR_print_errors_fp (stderr);