summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-04-20 20:34:48 +0800
committerChocobo12017-04-20 20:36:08 +0800
commit37357a94b865f2cf83f794cda26e60d405efccc1 (patch)
tree475bb0ef58a67ac9ac327fc4ab1a5034aa0f6bda
downloadaur-37357a94b865f2cf83f794cda26e60d405efccc1.tar.gz
newpkg: httperf-git 1-cc88843-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52cf8b57859b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = httperf-git
+ pkgdesc = The HTTP load generator
+ pkgver = cc88843
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/httperf/httperf
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = httperf
+ conflicts = httperf
+ source = git+https://github.com/httperf/httperf.git
+ sha256sums = SKIP
+
+pkgname = httperf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7847d72b4747
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=httperf-git
+pkgver=cc88843
+pkgrel=1
+epoch=1
+pkgdesc="The HTTP load generator"
+arch=('i686' 'x86_64')
+url="https://github.com/httperf/httperf"
+license=('GPL')
+#depends=('libchewing' 'qt5-base' 'hicolor-icon-theme')
+makedepends=('git')
+provides=('httperf')
+conflicts=('httperf')
+source=("git+https://github.com/httperf/httperf.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "httperf"
+
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "httperf"
+
+ autoreconf -i
+ mkdir -p "build"
+}
+
+build() {
+ cd "httperf/build"
+
+ ../configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "httperf/build"
+
+ make DESTDIR="$pkgdir" install
+}