summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredward-p2019-06-29 00:59:33 +0800
committeredward-p2019-06-29 00:59:33 +0800
commite6e8fb84cea0bb2ab380705fdd5e9e8595f6e2eb (patch)
treec772e566a3705ca8cc7386988a7e780570cf454d
downloadaur-e6e8fb84cea0bb2ab380705fdd5e9e8595f6e2eb.tar.gz
init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04881b6948bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = httpflow-git
+ pkgdesc = Packet capture and analysis utility similar to tcpdump for HTTP
+ pkgver = r45.14ec857
+ pkgrel = 1
+ url = https://github.com/six-ddc/httpflow
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libpcap
+ depends = zlib
+ depends = pcre
+ source = httpflow-git::git+https://github.com/six-ddc/httpflow.git
+ sha256sums = SKIP
+
+pkgname = httpflow-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5d439b3cfda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Edward Pacman <edward@edward-p.xyz>
+
+pkgname=httpflow-git
+pkgver=r45.14ec857
+pkgrel=1
+pkgdesc="Packet capture and analysis utility similar to tcpdump for HTTP"
+arch=('x86_64')
+url="https://github.com/six-ddc/httpflow"
+license=('MIT')
+depends=('libpcap' 'zlib' 'pcre')
+makedepends=(git)
+
+source=("${pkgname}::git+https://github.com/six-ddc/httpflow.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build(){
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ # Install dkms.conf
+ cd "${pkgname}"
+ PREFIX="${pkgdir}/usr" make install
+}