summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Chain2017-02-23 08:39:11 -0300
committerGustavo Chain2017-02-23 08:39:11 -0300
commitb16c44b861559b055e8be32d0463f5717d07cc3e (patch)
tree3fafa9077887689cf984fe185d80b9f2cd460115
downloadaur-b16c44b861559b055e8be32d0463f5717d07cc3e.tar.gz
First working version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..090bb49a5c70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = httplab
+ pkgdesc = An interactive web server
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://github.com/gchaincl/httplab
+ arch = any
+ license = MIT
+ makedepends = go>=1.7
+ provides = httplab=$pkgver
+ conflicts = httplab
+ replaces = httplab
+ source = httplab::git+https://github.com/gchaincl/httplab.git
+ md5sums = SKIP
+
+pkgname = httplab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2cf4ad9afea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Gustavo Chain <gchain@gmail.com>
+pkgname=httplab
+pkgver=0.1
+pkgrel=1
+pkgdesc="An interactive web server"
+arch=(any)
+url="http://github.com/gchaincl/httplab"
+license=('MIT')
+makedepends=('go>=1.7')
+provides=('httplab=$pkgver')
+conflicts=('httplab')
+replaces=('httplab')
+install=
+source=("$pkgname"::'git+https://github.com/gchaincl/httplab.git')
+md5sums=(SKIP)
+
+build() {
+ cd "$pkgname"
+ go build
+}
+
+package() {
+ cd "$pkgname"
+ install -D -s -m644 httplab "${pkgdir}/usr/bin/httplab"
+}