summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2020-03-25 17:20:57 +0700
committerkhai96_2020-03-25 17:20:57 +0700
commit87dcaa3dfd9216dd1f300fc806bce5fe258bf886 (patch)
tree2988727b38fc96c1b3567c25edb52ca47cfdab7a
parent3af446fae86b38a04a2bc25f0645c25a59a9e0e5 (diff)
downloadaur-87dcaa3dfd9216dd1f300fc806bce5fe258bf886.tar.gz
Convert to httplz
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD24
2 files changed, 25 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb47399ea3f9..1d6a8ac07171 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
-pkgbase = miniserve-bin
- pkgdesc = Tool to serve files via HTTP
- pkgver = 0.6.0
- pkgrel = 2
- url = https://github.com/svenstaro/miniserve
+pkgbase = httplz-bin
+ pkgdesc = Host These Things Please - a basic http server for hosting a folder fast and simply
+ pkgver = 1.9.1
+ pkgrel = 0
+ url = https://github.com/thecoshman/http
arch = x86_64
license = MIT
- provides = miniserve
- conflicts = miniserve
- source = miniserve-0.6.0::https://github.com/svenstaro/miniserve/releases/download/v0.6.0/miniserve-linux-x86_64
- source = https://github.com/svenstaro/miniserve/raw/v0.6.0/LICENSE
+ noextract = http-man-v1.9.1.tbz2
+ source = https://github.com/thecoshman/http/releases/download/v1.9.1/http-v1.9.1
+ source = https://github.com/thecoshman/http/releases/download/v1.9.1/http-man-v1.9.1.tbz2
+ source = https://github.com/thecoshman/http/raw/v1.9.1/LICENSE
+ sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
-pkgname = miniserve-bin
+pkgname = httplz-bin
diff --git a/PKGBUILD b/PKGBUILD
index 10a45756eb82..c055a2ebce2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
# Maintainer: Hoàng Văn Khải <hvksmr1996@gmail.com>
-pkgname=miniserve-bin
-_pkgname=miniserve
-pkgver=0.6.0
-pkgrel=2
-pkgdesc="Tool to serve files via HTTP"
-provides=('miniserve')
-conflicts=('miniserve')
+pkgname=httplz-bin
+_pkgname=httplz
+pkgver=1.9.1
+pkgrel=0
+pkgdesc='Host These Things Please - a basic http server for hosting a folder fast and simply'
arch=('x86_64')
-url="https://github.com/svenstaro/miniserve"
+url="https://github.com/thecoshman/http"
license=(MIT)
source=(
- miniserve-${pkgver}::${url}/releases/download/v${pkgver}/miniserve-linux-x86_64
+ ${url}/releases/download/v${pkgver}/http-v${pkgver}
+ ${url}/releases/download/v${pkgver}/http-man-v${pkgver}.tbz2
${url}/raw/v${pkgver}/LICENSE
)
sha512sums=(
SKIP
SKIP
+ SKIP
+)
+noextract=(
+ http-man-v${pkgver}.tbz2
)
package() {
- install -Dm755 miniserve-${pkgver} "$pkgdir"/usr/bin/miniserve
+ install -Dm755 http-v${pkgver} "$pkgdir"/usr/bin/httplz
+ install -Dm644 http-man-v${pkgver}.tbz2 "$pkgdir"/usr/share/man/man1/httplz.tbz2
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}