summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorben Günther2020-08-07 01:50:57 +0200
committerThorben Günther2020-08-07 01:50:57 +0200
commit57ef1530dfb9c8b5b9114b95bb7783064863f994 (patch)
tree6b9a1539b03fa69377d9dd90c165546cc128bfcf
downloadaur-57ef1530dfb9c8b5b9114b95bb7783064863f994.tar.gz
Initial upload: httpobs-git r650.b267848-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e13fa3256c29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = httpobs-git
+ pkgdesc = A command line tool to scan your website
+ pkgver = r650.b267848
+ pkgrel = 1
+ url = https://github.com/mozilla/http-observatory
+ arch = any
+ license = custom:MPL2
+ makedepends = python-setuptools
+ depends = python-celery
+ depends = python-beautifulsoup4
+ depends = python-publicsuffixlist
+ provides = httpobs
+ conflicts = httpobs
+ source = httpobs::git+https://github.com/mozilla/http-observatory
+ sha256sums = SKIP
+
+pkgname = httpobs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0ad794558c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Thorben Günther <echo YWRtaW5AeGVucm94Lm5ldAo= | base64 -d>
+
+pkgname=httpobs-git
+_pkgname=httpobs
+pkgver=r650.b267848
+pkgrel=1
+pkgdesc='A command line tool to scan your website'
+arch=('any')
+url='https://github.com/mozilla/http-observatory'
+license=('custom:MPL2')
+depends=('python-celery' 'python-beautifulsoup4' 'python-publicsuffixlist')
+makedepends=('python-setuptools')
+provides=('httpobs')
+conflicts=('httpobs')
+source=(
+ "$_pkgname::git+https://github.com/mozilla/http-observatory"
+)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ (
+ set -o pipefail
+ git describe --long 2> /dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}