summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYardena Cohen2019-10-12 22:54:32 -0700
committerYardena Cohen2019-10-12 22:54:32 -0700
commit371d88b4057c39b68e9f0adf8c6df0b64c64938e (patch)
tree694fcf63e5a5382a2ee87d698b422c38461863fb
parent259b257623a8b0c7cf35dda13ff7d630cb1dedbb (diff)
downloadaur-371d88b4057c39b68e9f0adf8c6df0b64c64938e.tar.gz
needs submodules
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
index b6902cc12ee6..f5bfac5816d1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
https-everywhere-chrome-git-*-any.pkg.tar.xz
https-everywhere-chrome-git-*.log
https-everywhere/
+https-everywhere-lib-wasm/
+translation/
PKGBUILD-namcap.log
diff --git a/PKGBUILD b/PKGBUILD
index f1c366ee54d5..9adec63d33b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,33 @@
pkgsubn=https-everywhere
pkgname=${pkgsubn}-chrome-git
-pkgver=64806.7885b8871c
-pkgrel=1
+pkgver=66380.17bc164712
+pkgrel=2
pkgdesc="Chrome/Chromium extension to use HTTPS whenever possible - git/dev"
arch=('any')
url='https://www.eff.org/https-everywhere'
license=('GPL')
makedepends=(git perl python36 python-lxml libxml2 vim zip rsync)
-source=("git+https://github.com/EFForg/${pkgsubn}.git")
-sha512sums=('SKIP')
+depends=(chromium)
+source=(
+ "git+https://github.com/EFForg/${pkgsubn}.git"
+ "git+https://github.com/EFForg/${pkgsubn}-lib-wasm.git"
+ "git+https://git.torproject.org/translation.git"
+)
+sha512sums=(SKIP SKIP SKIP)
pkgver() {
cd "${srcdir}/${pkgsubn}"
local ver="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
printf "%s" "${ver//-/.}"
}
+prepare() {
+ cd "${srcdir}/${pkgsubn}"
+ git submodule init
+ git config submodule.lib-wasm.url "${srcdir}/${pkgsubn}-lib-wasm"
+ git config submodule.translate.url "${srcdir}/translation"
+ git submodule update
+}
build() {
cd "${srcdir}/${pkgsubn}"
./make.sh