summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author46792017-04-21 11:00:53 +0800
committer46792017-04-21 11:00:53 +0800
commita764daaa04a9fca9cc65ba49043abd28d7e66a13 (patch)
treeae932a60759407b15a0b35766a59b89b111ab2a9
downloadaur-a764daaa04a9fca9cc65ba49043abd28d7e66a13.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7656d53409f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = httpstat-go
+ pkgdesc = It's like curl -v, with colours.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/davecheney/httpstat
+ arch = x86_64
+ arch = i686
+ license = MIT
+ source_x86_64 = httpstat::https://github.com/davecheney/httpstat/releases/download/v1.0.0/httpstat-linux-amd64-v1.0.0
+ md5sums_x86_64 = 9389453ae98f90c1514ae4b60049ac10
+ source_i686 = httpstat::https://github.com/davecheney/httpstat/releases/download/v1.0.0/httpstat-linux-386-v1.0.0
+ md5sums_i686 = 9389453ae98f90c1514ae4b60049ac10
+
+pkgname = httpstat-go
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f68a5eec31a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: 4679kun <4679kun@outlook.com>
+
+pkgname=httpstat-go
+_pkgname=httpstat
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="It's like curl -v, with colours."
+arch=('x86_64' 'i686')
+url="https://github.com/davecheney/httpstat"
+license=('MIT')
+if [ "$CARCH" = "i686" ]; then
+ _PKGARCH=386
+else
+ _PKGARCH=amd64
+fi
+source_x86_64=("httpstat::https://github.com/davecheney/httpstat/releases/download/v1.0.0/httpstat-linux-amd64-v1.0.0")
+source_i686=("httpstat::https://github.com/davecheney/httpstat/releases/download/v1.0.0/httpstat-linux-386-v1.0.0")
+md5sums_x86_64=('9389453ae98f90c1514ae4b60049ac10')
+md5sums_i686=('9389453ae98f90c1514ae4b60049ac10')
+
+package() {
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}