summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaime Martínez Rincón2021-12-23 01:07:58 +0100
committerJaime Martínez Rincón2021-12-23 01:07:58 +0100
commit2c718b48c8a799afa916d6e1514b7c2199be7fc4 (patch)
tree123ac33c336d6b05360fba7eb0de5a0b2b49d8a8
parent788a68a5b0decf87eb5340b024da10cd51593455 (diff)
downloadaur-2c718b48c8a799afa916d6e1514b7c2199be7fc4.tar.gz
Add symlink to app in bin
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f81ba812ee9c..f91745508d6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = httptoolkit-bin
pkgdesc = Beautiful, cross-platform & open-source HTTP(S) proxy, analyzer and client.
pkgver = 1.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://httptoolkit.tech/
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index e1dca1e0d8b5..0d50ec39ea1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=httptoolkit-bin
pkgver=1.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="Beautiful, cross-platform & open-source HTTP(S) proxy, analyzer and client."
arch=("x86_64")
url="https://httptoolkit.tech/"
@@ -24,9 +24,18 @@ validpgpkeys=()
md5sums=('13288661942e6aa8f578a2d823f00f4d')
package() {
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/opt/HTTP Toolkit"
+ install -d "${pkgdir}/usr/share/icons"
+ install -d "${pkgdir}/usr/share/doc"
+ install -d "${pkgdir}/usr/share/applications"
+
# Extract package fs from deb
bsdtar -O -xf "HttpToolkit-${pkgver}.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
# Set all directories to 755 mode
- find "${pkgdir}" -type d -exec chmod 755 {} +
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ # Add symlink to bin
+ ln -s "/opt/HTTP Toolkit/httptoolkit" "${pkgdir}/usr/bin/httptoolkit"
}