summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Saparelli2015-06-20 15:57:17 +1200
committerFélix Saparelli2015-06-20 15:57:17 +1200
commit180101dc3fdfc3012af66bc570241a932d63647b (patch)
treeebb06daec69c95d6e5e8993a94dc5b3f423b6304
downloadaur-180101dc3fdfc3012af66bc570241a932d63647b.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--hub-bin.install7
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa3a6b0b863e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hub-bin
+ pkgdesc = hub helps you win at git. Go-powered version
+ pkgver = 2.2.0
+ pkgrel = 8
+ url = https://hub.github.com
+ install = hub-bin.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = https://github.com/github/hub/releases/download/v2.2.0/hub-linux-amd64-2.2.0.tar.gz
+ sha512sums = b982c9345164b8c4afeb1b679cf129293cd441940bab8645699328b872d77ecc228cd4a1f6e95f2e71b553591636aab519c7c5ac43c7a8f771b1f80c05751465
+
+pkgname = hub-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a52315f05eb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Félix "passcod" Saparelli <aur@passcod.name>
+# Contributor: Matthieu "CircleCode" Codron <codronm+circlecode@gmail.com>
+# Contributor: Niklas Heer <niklas.heer@gmail.com>
+pkgname=hub-bin
+pkgver=2.2.0
+pkgrel=8
+pkgdesc="hub helps you win at git. Go-powered version"
+arch=('i686' 'x86_64')
+url="https://hub.github.com"
+license=('MIT')
+_arch=amd64 # Workaround for mkaurball: https://bugs.archlinux.org/task/40711
+[[ $CARCH = i686 ]] && _arch=386
+source=("https://github.com/github/hub/releases/download/v${pkgver}/hub-linux-${_arch}-${pkgver}.tar.gz")
+sha512sums=('b982c9345164b8c4afeb1b679cf129293cd441940bab8645699328b872d77ecc228cd4a1f6e95f2e71b553591636aab519c7c5ac43c7a8f771b1f80c05751465')
+[[ $CARCH = i686 ]] && sha512sums=('dcba7563b5635f3d914e97fa8c3291983ae5ed70b6cd4232f9894d27d7387e12d4bad67ecb075fed6ede4af352a41c54983862d21640b1ccaff1340578bfcefd')
+install='hub-bin.install'
+package() {
+ cd $srcdir/hub-linux-${_arch}-${pkgver}
+ install -Dm755 {,$pkgdir/usr/bin/}hub
+ install -Dm644 {etc/,$pkgdir/usr/share/git/completion/}hub.bash_completion.sh
+ install -Dm644 etc/hub.zsh_completion "$pkgdir/usr/local/share/zsh/site-functions/_hub"
+}
diff --git a/hub-bin.install b/hub-bin.install
new file mode 100644
index 000000000000..c6373d06ba9e
--- /dev/null
+++ b/hub-bin.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Run \`$ hub alias\` in your preferred shell to receive the appropriate setup instructions."
+}
+
+post_remove() {
+ echo "You may want to remove references to hub in your shell's config files"
+}