summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Grossar2019-10-02 09:54:29 +0200
committerLukas Grossar2019-10-02 09:58:12 +0200
commit5f0527ce2a4edfcfe8813c80cf91460ebb30ef71 (patch)
tree64430a89be5f28c8c4d63e41e479d2071863ff25
parent180101dc3fdfc3012af66bc570241a932d63647b (diff)
downloadaur-5f0527ce2a4edfcfe8813c80cf91460ebb30ef71.tar.gz
update to hub-bin v2.12.7
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
-rw-r--r--hub-bin.install7
3 files changed, 21 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa3a6b0b863e..01c5bd9c8950 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = hub-bin
- pkgdesc = hub helps you win at git. Go-powered version
- pkgver = 2.2.0
- pkgrel = 8
+ pkgdesc = A command-line tool that makes git easier to use with GitHub
+ pkgver = 2.12.7
+ pkgrel = 1
url = https://hub.github.com
- install = hub-bin.install
- arch = i686
arch = x86_64
license = MIT
- source = https://github.com/github/hub/releases/download/v2.2.0/hub-linux-amd64-2.2.0.tar.gz
- sha512sums = b982c9345164b8c4afeb1b679cf129293cd441940bab8645699328b872d77ecc228cd4a1f6e95f2e71b553591636aab519c7c5ac43c7a8f771b1f80c05751465
+ depends = git
+ source = https://github.com/github/hub/releases/download/v2.12.7/hub-linux-amd64-2.12.7.tgz
+ sha256sums = 5ba5ea455659f02c162553bc8b01fb8a6ccca3c21f8a80b054cce02ed28a36a2
pkgname = hub-bin
diff --git a/PKGBUILD b/PKGBUILD
index a52315f05eb8..737e12c6347f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# Maintainer: FĂ©lix "passcod" Saparelli <aur@passcod.name>
-# Contributor: Matthieu "CircleCode" Codron <codronm+circlecode@gmail.com>
-# Contributor: Niklas Heer <niklas.heer@gmail.com>
+# Maintainer: Lukas Grossar <lukas.grossar@gmail.com>
+
pkgname=hub-bin
-pkgver=2.2.0
-pkgrel=8
-pkgdesc="hub helps you win at git. Go-powered version"
-arch=('i686' 'x86_64')
+pkgver=2.12.7
+pkgrel=1
+pkgdesc="A command-line tool that makes git easier to use with GitHub"
+arch=('x86_64')
url="https://hub.github.com"
+depends=('git')
license=('MIT')
-_arch=amd64 # Workaround for mkaurball: https://bugs.archlinux.org/task/40711
-[[ $CARCH = i686 ]] && _arch=386
-source=("https://github.com/github/hub/releases/download/v${pkgver}/hub-linux-${_arch}-${pkgver}.tar.gz")
-sha512sums=('b982c9345164b8c4afeb1b679cf129293cd441940bab8645699328b872d77ecc228cd4a1f6e95f2e71b553591636aab519c7c5ac43c7a8f771b1f80c05751465')
-[[ $CARCH = i686 ]] && sha512sums=('dcba7563b5635f3d914e97fa8c3291983ae5ed70b6cd4232f9894d27d7387e12d4bad67ecb075fed6ede4af352a41c54983862d21640b1ccaff1340578bfcefd')
-install='hub-bin.install'
+source=("https://github.com/github/hub/releases/download/v${pkgver}/hub-linux-amd64-${pkgver}.tgz")
+sha256sums=('5ba5ea455659f02c162553bc8b01fb8a6ccca3c21f8a80b054cce02ed28a36a2')
+
package() {
- cd $srcdir/hub-linux-${_arch}-${pkgver}
- install -Dm755 {,$pkgdir/usr/bin/}hub
- install -Dm644 {etc/,$pkgdir/usr/share/git/completion/}hub.bash_completion.sh
- install -Dm644 etc/hub.zsh_completion "$pkgdir/usr/local/share/zsh/site-functions/_hub"
+ prefix="${pkgdir}/usr" "${srcdir}/hub-linux-amd64-${pkgver}/install"
+
+ install -Dm644 "${srcdir}/hub-linux-amd64-${pkgver}/etc/hub.bash_completion.sh" "$pkgdir/usr/share/bash-completion/completions/hub"
+ install -Dm644 "${srcdir}/hub-linux-amd64-${pkgver}/etc/hub.zsh_completion" "$pkgdir/usr/share/zsh/site-functions/_hub"
+ install -Dm644 "${srcdir}/hub-linux-amd64-${pkgver}/etc/hub.fish_completion" "$pkgdir/usr/share/fish/completions/hub.fish"
}
diff --git a/hub-bin.install b/hub-bin.install
deleted file mode 100644
index c6373d06ba9e..000000000000
--- a/hub-bin.install
+++ /dev/null
@@ -1,7 +0,0 @@
-post_install() {
- echo "Run \`$ hub alias\` in your preferred shell to receive the appropriate setup instructions."
-}
-
-post_remove() {
- echo "You may want to remove references to hub in your shell's config files"
-}