summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCelestialWalrus2015-07-16 05:02:01 -0400
committerCelestialWalrus2015-07-16 05:02:01 -0400
commit88d0289a6decde8d03d16ce24c60538d38ae8143 (patch)
tree802cb9210484cc55e7accd8990fed8fe7d117514
downloadaur-88d0289a6decde8d03d16ce24c60538d38ae8143.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..445e5c8fab51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hub-git
+ pkgdesc = hub introduces git to GitHub
+ pkgver = 2.2.0.27.g64187e3
+ pkgrel = 1
+ epoch = 1
+ url = http://hub.github.com
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = git
+ provides = hub
+ conflicts = hub
+ conflicts = hub-rubygem-git
+ replaces = hub-rubygem-git
+ source = hub::git://github.com/github/hub.git
+ md5sums = SKIP
+
+pkgname = hub-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cd59d28d0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Daniel Wallace: <danielwallace at gtmanfred dot com>
+# Contributor: Alfredo Palhares <masterkorp@masterkorp.net>
+# Contributor: Simon Kohlmeyer <simon.kohlmeyer@gmail.com>
+
+pkgname=hub-git
+_pkgname=hub
+pkgver=2.2.0.27.g64187e3
+epoch=1
+pkgver(){
+ cd $_pkgname
+ git describe --tags | sed 's/-/./g;s/^v//'
+}
+pkgrel=1
+pkgdesc="hub introduces git to GitHub"
+arch=('x86_64')
+url="http://hub.github.com"
+depends=('git')
+makedepends=('go')
+license=('MIT')
+source=($_pkgname::git://github.com/github/hub.git)
+md5sums=('SKIP')
+conflicts=('hub' 'hub-rubygem-git')
+provides=('hub')
+replaces=('hub-rubygem-git')
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./script/build
+ gzip --best -c man/$_pkgname.1> $_pkgname.1.gz
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "etc/hub.bash_completion.sh" "$pkgdir/usr/share/bash-completion/completions/hub"
+ install -Dm644 "etc/hub.zsh_completion" "$pkgdir/usr/share/zsh/site-functions/_hub"
+
+ install -Dm644 "man/$_pkgname.1" "$pkgdir/usr/share/man/man1/$_pkgname.1"
+}
+