summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonne Haß2016-08-09 14:09:28 +0200
committerJonne Haß2016-08-09 15:46:42 +0200
commitfec83d4e1354db77f0d648bb34d8cdfccbfc710a (patch)
tree8eefc68d71719a26126d08ddeafcd74447720a94
parent88d0289a6decde8d03d16ce24c60538d38ae8143 (diff)
downloadaur-fec83d4e1354db77f0d648bb34d8cdfccbfc710a.tar.gz
hub-git: add
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD57
3 files changed, 37 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 445e5c8fab51..39487a975fbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Aug 9 12:08:25 UTC 2016
pkgbase = hub-git
- pkgdesc = hub introduces git to GitHub
- pkgver = 2.2.0.27.g64187e3
+ pkgdesc = cli interface for Github
+ pkgver = v2.2.0.preview1.r400.g713fd93
pkgrel = 1
- epoch = 1
- url = http://hub.github.com
+ url = https://hub.github.com
arch = x86_64
+ arch = i686
license = MIT
makedepends = go
+ makedepends = groff
+ makedepends = ruby-bundler
depends = git
provides = hub
conflicts = hub
- conflicts = hub-rubygem-git
- replaces = hub-rubygem-git
- source = hub::git://github.com/github/hub.git
- md5sums = SKIP
+ source = git+https://github.com/github/hub.git
+ sha256sums = SKIP
pkgname = hub-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6d3df53e7e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+hub/
diff --git a/PKGBUILD b/PKGBUILD
index 2cd59d28d0e5..404cac81b1b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,37 @@
-# Maintainer: Daniel Wallace: <danielwallace at gtmanfred dot com>
-# Contributor: Alfredo Palhares <masterkorp@masterkorp.net>
-# Contributor: Simon Kohlmeyer <simon.kohlmeyer@gmail.com>
-
+# Maintainer: Jonne Haß <me@jhass.eu>
pkgname=hub-git
-_pkgname=hub
-pkgver=2.2.0.27.g64187e3
-epoch=1
-pkgver(){
- cd $_pkgname
- git describe --tags | sed 's/-/./g;s/^v//'
-}
+pkgver=v2.2.0.preview1.r400.g713fd93
pkgrel=1
-pkgdesc="hub introduces git to GitHub"
-arch=('x86_64')
-url="http://hub.github.com"
-depends=('git')
-makedepends=('go')
+pkgdesc="cli interface for Github"
+url="https://hub.github.com"
+arch=('x86_64' 'i686')
license=('MIT')
-source=($_pkgname::git://github.com/github/hub.git)
-md5sums=('SKIP')
-conflicts=('hub' 'hub-rubygem-git')
+conflicts=('hub')
provides=('hub')
-replaces=('hub-rubygem-git')
+depends=('git')
+makedepends=('go' 'groff' 'ruby-bundler')
+source=("git+https://github.com/github/hub.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname/-git/}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd "$srcdir/$_pkgname"
- ./script/build
- gzip --best -c man/$_pkgname.1> $_pkgname.1.gz
+ cd "$srcdir/${pkgname/-git/}"
+
+ make all man-pages
}
package() {
- cd "$srcdir/$_pkgname"
- install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ cd "$srcdir/${pkgname/-git/}"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "etc/hub.bash_completion.sh" "$pkgdir/usr/share/bash-completion/completions/hub"
- install -Dm644 "etc/hub.zsh_completion" "$pkgdir/usr/share/zsh/site-functions/_hub"
-
- install -Dm644 "man/$_pkgname.1" "$pkgdir/usr/share/man/man1/$_pkgname.1"
+ install -Dm755 bin/hub "$pkgdir/usr/bin/hub"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname/-git/}/LICENSE"
+ install -Dm644 etc/hub.bash_completion.sh "$pkgdir/usr/share/bash-completion/completions/hub"
+ install -Dm644 etc/hub.zsh_completion "$pkgdir/usr/share/zsh/site-functions/_hub"
+ for manpage in man/hub.1 man/hub-*.1; do
+ install -Dm644 $manpage "$pkgdir/usr/share/man/man1/$(basename $manpage)"
+ done
}
-