summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2015-08-10 13:01:23 +0200
committerÉtienne Deparis2015-08-10 13:01:23 +0200
commitd652299ef7a0a9f4e4421fc228df996915f01cca (patch)
tree2f17b6d219e09f8cc48477a4a46018098cb3a4a6
downloadaur-d652299ef7a0a9f4e4421fc228df996915f01cca.tar.gz
Take back hubic on AUR
-rw-r--r--.SRCINFO18
-rw-r--r--CHANGELOG65
-rw-r--r--PKGBUILD25
-rw-r--r--hubic.install13
4 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e268d143b5e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Mon Aug 10 11:00:06 UTC 2015
+pkgbase = hubic
+ pkgdesc = Synchronization service provided by OVH.
+ pkgver = 2.1.0
+ pkgrel = 55
+ url = https://hubic.com/
+ install = hubic.install
+ changelog = CHANGELOG
+ arch = any
+ license = custom
+ depends = mono>=2.10
+ provides = hubic
+ source = http://mir7.ovh.net/ovh-applications/hubic/hubiC-Linux/2.1.0/hubiC-Linux-2.1.0.53-linux.tar.gz
+ sha1sums = 67c7a51325271945414f2c3c61eb371a908ea43b
+
+pkgname = hubic
+
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..e1e1b6814720
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,65 @@
+hubic (2.1.0) unstable; urgency=low
+
+ * Added: proxy authentication handling
+ * Added: backups can be created inside synchronization
+ * Added: synchronization can be disabled
+ * Fixed: backup upload could be interrupted by network errors
+ * Fixed: error 400 when a backup was deleted and the recreated with same name
+ * Fixed: crash when actions on backup were attempted during pause
+ * Fixed: the 'kept_versions' switch on backup creation was not handled
+ * Fixed: other minor bugs
+ * Changed: extra arguments now generates an error (they were silently ignored before)
+ * Changed: the libgdiplus library is no longer required to run the program
+
+ -- Julien <julien.desgats@ovh.net> Tue, 27 Jan 2015 16:20:42 +0200
+
+hubic (2.0.2-1) unstable; urgency=low
+
+ * Fixed: connection error with newly created accounts
+
+ -- Julien <julien@Mint-15-MATE> Mon, 20 Oct 2014 19:42:33 +0200
+
+hubic (2.0.1-1) unstable; urgency=low
+
+ * Fixed: last backup display when there is no backup
+ * Fixed: data blocks were kept even after file deletion in some cases
+ * Fixed: backup/synchronisation scheduling was sometimes mixed
+
+ -- Julien <julien@Mint-15-MATE> Mon, 20 Oct 2014 19:42:23 +0200
+
+hubic (2.0.0-1) unstable; urgency=low
+
+ * Added backup feature (DBus API and CLI interface)
+
+ -- Julien <julien.desgats@ovh.net> Mon, 29 Sep 2014 09:45:43 +0200
+
+hubic (1.2.5.38-1) unstable; urgency=low
+
+ * Added publication duration
+ * At startup, wait for Internet connection to be up before trying to connect to hubiC
+ * Fixed: behavior for some conflicts
+ * Added support for upcoming OpenStack features
+ * Other minor bug fixes
+
+ -- Julien <julien.desgats@ovh.net> Tue, 26 Aug 2014 13:48:58 GMT
+
+hubic (1.2.4.35-1) unstable; urgency=low
+
+ * Backport of Windows 1.2.4 features
+ * Fixed some connection issues
+ * Improved symbolic link handling
+
+ -- Julien <julien.desgats@ovh.net> Wed, 14 May 2014 12:16:21 +0200
+
+hubic (1.1.12.1-1) unstable; urgency=low
+
+ * Added messages history in DBus API and status output
+ * Some documentation fixes
+
+ -- Julien Desgats <julien.desgats@ovh.net> Wed, 9 Oct 2013 13:08:00 +0200
+
+hubic (1.1.12.0-1) unstable; urgency=low
+
+ * First public release
+
+ -- Julien Desgats <julien.desgats@ovh.net> Mon, 30 Sep 2013 19:11:27 +0200
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd1b637a9ff8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Étienne Deparis <etienne [at] depar [dot] is>
+# Creator: casimir <aur.casimir-lab.net>
+
+pkgname=hubic
+pkgver=2.1.0
+_pkgbuildver=53
+pkgrel=55
+pkgdesc="Synchronization service provided by OVH."
+arch=('any')
+url="https://hubic.com/"
+license=('custom')
+provides=('hubic')
+depends=('mono>=2.10')
+install=hubic.install
+changelog=CHANGELOG
+source=(http://mir7.ovh.net/ovh-applications/hubic/hubiC-Linux/${pkgver}/hubiC-Linux-${pkgver}.${_pkgbuildver}-linux.tar.gz)
+sha1sums=('67c7a51325271945414f2c3c61eb371a908ea43b')
+
+package() {
+ cd "$pkgname"
+ make PREFIX="$pkgdir/usr" RUNTIME_PREFIX="/usr" DBUSSERVICE_DIR="$pkgdir/usr/share/dbus-1/services" install
+ install -dm 755 $pkgdir/usr/share/licenses/hubic
+ mv $pkgdir/usr/share/doc/hubic/copyright $pkgdir/usr/share/licenses/hubic/LICENSE
+ install -Dm 644 doc/Contrat_hubiC_2013.pdf $pkgdir/usr/share/licenses/hubic/CGU-fr_FR.pdf
+}
diff --git a/hubic.install b/hubic.install
new file mode 100644
index 000000000000..b43946e0b71c
--- /dev/null
+++ b/hubic.install
@@ -0,0 +1,13 @@
+dbus_tip() {
+ echo "If it doesn't launch when in an ssh session try something like:"
+ echo "\$ export \$(dbus-launch); hubic args"
+}
+
+post_install() {
+ echo "Don't forget to run 'hubiC login <email> <folder to synchronize>' to initialize the service."
+ dbus_tip
+}
+
+post_upgrade() {
+ dbus_tip
+}