summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-06-06 10:55:22 -0600
committerMark Wagie2022-06-06 10:55:22 -0600
commit5be38f93aeb9a67aeaabbfaf87bf41d978eb6759 (patch)
tree11a9f5f390dead5b943e7b28d05ef23f2154eee5
parent888e1c034bb6a2164ae5c00b92249c2a812291b5 (diff)
downloadaur-5be38f93aeb9a67aeaabbfaf87bf41d978eb6759.tar.gz
0.4.8
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0dd0575acbc..356c87b8d5b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = huekeys
pkgdesc = Control the keyboard backlight on System76 laptops
- pkgver = 0.4.5
+ pkgver = 0.4.8
pkgrel = 1
url = https://github.com/BitPonyLLC/huekeys
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = huekeys
makedepends = go
depends = gtk3
depends = libayatana-appindicator
- source = git+https://github.com/BitPonyLLC/huekeys.git#commit=da72dc74a2168b5d5227dadf6624362bb6e182d7
+ source = git+https://github.com/BitPonyLLC/huekeys.git#commit=51554208a0238cb0971e56eed84ccf49df7995e1
sha256sums = SKIP
pkgname = huekeys
diff --git a/PKGBUILD b/PKGBUILD
index 739335b5f2b4..ae64e91cfe1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=huekeys
-pkgver=0.4.5
+pkgver=0.4.8
pkgrel=1
pkgdesc="Control the keyboard backlight on System76 laptops"
arch=('x86_64')
@@ -8,10 +8,15 @@ url="https://github.com/BitPonyLLC/huekeys"
license=('MIT')
depends=('gtk3' 'libayatana-appindicator')
makedepends=('git' 'go')
-_commit=da72dc74a2168b5d5227dadf6624362bb6e182d7
+_commit=51554208a0238cb0971e56eed84ccf49df7995e1
source=("git+https://github.com/BitPonyLLC/huekeys.git#commit=${_commit}")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
prepare() {
cd "$srcdir/$pkgname"
export GOPATH="$srcdir/gopath"