summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-01-23 23:10:45 +0100
committerFabioLolix2022-01-23 23:10:45 +0100
commit89f19927ebca58f7b707292fa321cc1563ba061a (patch)
tree5d4d5fbb475d95ae1505e095d97f750951450930
parent39f70714b435d0bb2cf852b9fae55c2d10f15d5e (diff)
downloadaur-89f19927ebca58f7b707292fa321cc1563ba061a.tar.gz
revision
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD54
-rw-r--r--hugin.install19
3 files changed, 55 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e01273fadbe4..d42cc195d43d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,43 @@
pkgbase = hugin-hg
pkgdesc = A frontend to the panorama-tools
- pkgver = 7184.d888313bfc31
+ pkgver = r8405.de3609447749
pkgrel = 1
url = http://hugin.sourceforge.net/
- install = hugin.install
- arch = i686
arch = x86_64
license = GPL
makedepends = mercurial
makedepends = cmake
makedepends = boost
+ makedepends = tclap
+ makedepends = mesa
makedepends = swig
+ depends = wxgtk3
+ depends = boost-libs
+ depends = libtiff
+ depends = libpano13
+ depends = libjpeg
+ depends = libpng
depends = openexr
+ depends = vigra
depends = exiv2
- depends = wxgtk
- depends = boost-libs
- depends = libpano13>=2.9.19
- depends = python2
- depends = lensfun
depends = glew
+ depends = sqlite
+ depends = lcms2
+ depends = lapack
+ depends = fftw
+ depends = glu
+ depends = libxi
+ depends = libxmu
+ depends = python
+ depends = lensfun
depends = enblend-enfuse
- depends = perl-exiftool
- depends = desktop-file-utils
- optdepends = autopano-sift-c: automatic control point generator (obsolete)
+ optdepends = perl-image-exiftool: GPano tags support
+ optdepends = dcraw: RAW import using dcraw
+ optdepends = darktable: RAW import using darktable
+ optdepends = rawtherapee: RAW import using rawtherapee
provides = hugin
conflicts = hugin
source = hg+http://hg.code.sf.net/p/hugin/hugin
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = hugin-hg
-
diff --git a/PKGBUILD b/PKGBUILD
index 0d059bc5390a..988e9b44b64e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,48 @@
-# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+
pkgname=hugin-hg
-pkgver=7184.d888313bfc31
+pkgver=r8405.de3609447749
pkgrel=1
pkgdesc="A frontend to the panorama-tools"
-arch=('i686' 'x86_64')
+arch=(x86_64)
url="http://hugin.sourceforge.net/"
-license=('GPL')
-depends=('openexr' 'exiv2' 'wxgtk' 'boost-libs' 'libpano13>=2.9.19' 'python2' \
- 'lensfun' 'glew' 'enblend-enfuse' 'perl-exiftool' 'desktop-file-utils')
-makedepends=('mercurial' 'cmake' 'boost' 'swig')
-optdepends=('autopano-sift-c: automatic control point generator (obsolete)')
-provides=('hugin')
-conflicts=('hugin')
-install=hugin.install
-source=('hg+http://hg.code.sf.net/p/hugin/hugin')
-md5sums=('SKIP')
+license=(GPL)
+depends=(wxgtk3 boost-libs libtiff libpano13 libjpeg libpng openexr vigra
+ exiv2 glew sqlite lcms2 lapack fftw glu libxi libxmu python
+ lensfun enblend-enfuse)
+makedepends=(mercurial cmake boost tclap mesa swig)
+optdepends=('perl-image-exiftool: GPano tags support'
+ 'dcraw: RAW import using dcraw'
+ 'darktable: RAW import using darktable'
+ 'rawtherapee: RAW import using rawtherapee')
+provides=(hugin)
+conflicts=(hugin)
+source=("hg+http://hg.code.sf.net/p/hugin/hugin")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/hugin"
- echo $(hg identify -n).$(hg identify -i)
+ cd "${srcdir}/hugin"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
-build() {
- mkdir -p "$srcdir/build"
- cd "$srcdir/build"
+prepare() {
+ cd "${srcdir}/hugin"
+ [[ -d build ]] || mkdir build
+}
- cmake "$srcdir/hugin" \
+build() {
+ cd "${srcdir}/hugin/build"
+ cmake .. -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_LAPACK=yes \
-DBUILD_HSI=ON \
- -DCMAKE_SHARED_LINKER_FLAGS="-lpthread"
+ -DUSE_GDKBACKEND_X11=ON \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3
make
}
package() {
- cd "$srcdir/build"
+ cd "${srcdir}/hugin/build"
make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/hugin.install b/hugin.install
deleted file mode 100644
index a742032e8fc0..000000000000
--- a/hugin.install
+++ /dev/null
@@ -1,19 +0,0 @@
-
-post_install() {
- echo "updating desktop mime database..."
- update-desktop-database -q
- update-mime-database usr/share/mime > /dev/null 2>&1
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
-
-op=$1
-shift
-$op $*
-# vim: ft=sh