summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRizwan-Hasan2021-03-02 14:32:28 +0600
committerRizwan-Hasan2021-03-02 14:32:28 +0600
commit4e237623af8fc542f964916eaa2809a987922275 (patch)
tree93d330fe19b31d18ec09decd6e6b5c12a5815924
downloadaur-4e237623af8fc542f964916eaa2809a987922275.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67c8b1a15990
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hugo-extended
+ pkgdesc = Hugo is one of the most popular open-source static site generators. With its amazing speed and flexibility, Hugo makes building websites fun again.
+ pkgver = 0.81.0
+ pkgrel = 1
+ url = https://gohugo.io/
+ arch = x86_64
+ license = Apache v2.0
+ conflicts = hugo
+ conflicts = hugo-git
+ source = https://github.com/gohugoio/hugo/releases/download/v0.81.0/hugo_extended_0.81.0_Linux-64bit.tar.gz
+ sha256sums = 3c7d034405c67bf571b6d8f001d5a9c49dd87dbfa32b3b19d16e898c46f8f5e2
+
+pkgname = hugo-extended
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..863baf717d61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Rizwan Hasan <rizwan.hasan486@gmail.com>
+
+pkgname=hugo-extended
+pkgver=0.81.0
+pkgrel=1
+pkgdesc="Hugo is one of the most popular open-source static site generators. With its amazing speed and flexibility, Hugo makes building websites fun again."
+arch=('x86_64')
+url="https://gohugo.io/"
+license=('Apache v2.0')
+conflicts=('hugo' 'hugo-git')
+source=("https://github.com/gohugoio/hugo/releases/download/v0.81.0/hugo_extended_${pkgver}_Linux-64bit.tar.gz")
+sha256sums=("3c7d034405c67bf571b6d8f001d5a9c49dd87dbfa32b3b19d16e898c46f8f5e2")
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/opt/hugo"
+
+ cp -avr "hugo" "${pkgdir}/opt/hugo"
+ cp -avr "LICENSE" "${pkgdir}/opt/hugo"
+ cp -avr "README.md" "${pkgdir}/opt/hugo"
+
+ ln -sv "/opt/hugo/hugo" "${pkgdir}/usr/bin/hugo"
+}