summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlavi Pantaleev2023-11-13 11:45:45 +0200
committerSlavi Pantaleev2023-11-13 11:49:14 +0200
commit070b4a56418d089d8110bcf4a1606d0acf570e67 (patch)
treecdb94ed54bc1f72f0cef6ef4e79f3eeed33cc318
parent441a7752eee3c2804753108b316467bcbd3f36d3 (diff)
downloadaur-070b4a56418d089d8110bcf4a1606d0acf570e67.tar.gz
Switching to extracting the dictionaries from LibreOffice
Inspired by what hunspell-no does.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
2 files changed, 17 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02b66eb73e93..7ea64676cf3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = hunspell-bg
pkgdesc = Bulgarian dictionary for Hunspell
- pkgver = 4.3
- pkgrel = 2
- url = http://sourceforge.net/projects/bgoffice/
+ pkgver = 7.6.3.1
+ pkgrel = 0
+ url = https://bgoffice.sourceforge.net/
arch = any
license = GPL2
- license = LGPL2.1
- license = MPL
optdepends = hunspell: the spell checking libraries and apps
- source = http://sourceforge.net/projects/bgoffice/files/OpenOffice.org%20Spell%20BG/4.3/OOo-spell-bg-4.3.zip
- md5sums = ee804f871c855eb218c8d825b5fe54fb
+ source = https://download.documentfoundation.org/libreoffice/src/7.6.3/libreoffice-dictionaries-7.6.3.1.tar.xz
+ md5sums = 45ecbaed999bfab64a274c77e211ea8b
pkgname = hunspell-bg
-
diff --git a/PKGBUILD b/PKGBUILD
index 7a41e92d4154..76869a4556e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,24 @@
# Maintainer: Slavi Pantaleev <s.pantaleev at gmail.com>
pkgname=hunspell-bg
-pkgver=4.3
-pkgrel=2
+_LOver=7.6.3
+pkgver=7.6.3.1
+pkgrel=0
pkgdesc='Bulgarian dictionary for Hunspell'
arch=('any')
-url="http://sourceforge.net/projects/bgoffice/"
-license=('GPL2' 'LGPL2.1' 'MPL')
+url="https://bgoffice.sourceforge.net/"
+license=('GPL2')
optdepends=('hunspell: the spell checking libraries and apps')
-source=('http://sourceforge.net/projects/bgoffice/files/OpenOffice.org%20Spell%20BG/'$pkgver'/OOo-spell-bg-'$pkgver'.zip')
-md5sums=('ee804f871c855eb218c8d825b5fe54fb')
+source=("https://download.documentfoundation.org/libreoffice/src/${_LOver}/libreoffice-dictionaries-${pkgver}.tar.xz")
+md5sums=('45ecbaed999bfab64a274c77e211ea8b')
package() {
- cd "${srcdir}/OOo-spell-bg-${pkgver}"
+ cd "${srcdir}/libreoffice-${pkgver}/dictionaries/bg_BG/"
install -dm755 ${pkgdir}/usr/share/hunspell
+ install -m644 bg_BG.aff $pkgdir/usr/share/hunspell
+ install -m644 bg_BG.dic $pkgdir/usr/share/hunspell
- # UTF-8 convert
- conv='iconv -f windows-1251 -t utf-8'
- $conv bg_BG.dic > bg_BG_utf8.dic
- $conv bg_BG.aff | sed '1s/SET microsoft-cp1251/SET UTF-8/' > bg_BG_utf8.aff
- $conv README.bulgarian > README_bulgarian.txt
-
- install -m644 bg_BG_utf8.dic ${pkgdir}/usr/share/hunspell/bg_BG.dic
- install -m644 bg_BG_utf8.aff ${pkgdir}/usr/share/hunspell/bg_BG.aff
-
- # the symlinks
install -dm755 ${pkgdir}/usr/share/myspell/dicts
- pushd ${pkgdir}/usr/share/myspell/dicts
- for file in ${pkgdir}/usr/share/hunspell/*; do
- ln -sv /usr/share/hunspell/$(basename ${file}) .
- done
- popd
-
- # docs
- install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
- install -m644 README_bulgarian.txt ${pkgdir}/usr/share/doc/${pkgname}/
-
- # licenses
- install -dm755 ${pkgdir}/usr/share/licenses/${pkgname}
- install -m644 Copyright ${pkgdir}/usr/share/licenses/${pkgname}/Copyright
+ ln -sv /usr/share/hunspell/bg_BG.aff ${pkgdir}/usr/share/myspell/dicts/
+ ln -sv /usr/share/hunspell/bg_BG.dic ${pkgdir}/usr/share/myspell/dicts/
}