summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlois Nešpor2015-07-01 23:50:48 +0200
committerAlois Nešpor2015-07-01 23:50:48 +0200
commit9ceedda385b2ab64268c9dfe9b0d6b8a0c030905 (patch)
tree6579321ae77469f350eaff965ba071c04225ccf7
downloadaur-9ceedda385b2ab64268c9dfe9b0d6b8a0c030905.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc981dc02cc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hunspell-cs
+ pkgdesc = Czech hunspell/myspell dictionary
+ pkgver = 20061030
+ pkgrel = 1
+ url = http://ooo.mirror.dkm.cz/pub/openoffice/contrib/dictionaries/
+ arch = any
+ license = GPL2
+ license = custom
+ depends = hunspell
+ source = http://ooo.mirror.dkm.cz/pub/openoffice/contrib/dictionaries/cs_CZ-pack.zip
+ md5sums = a778a2a0df6abf505fd8b20a503414e0
+
+pkgname = hunspell-cs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f9e0c2ef90c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ondrej Kipila <ok100.ok100.ok100@gmail.com>
+
+pkgname=hunspell-cs
+pkgver=20061030
+pkgrel=1
+pkgdesc="Czech hunspell/myspell dictionary"
+arch=('any')
+url="http://ooo.mirror.dkm.cz/pub/openoffice/contrib/dictionaries/"
+license=('GPL2' 'custom')
+depends=('hunspell')
+source=(${url}cs_CZ-pack.zip)
+md5sums=('a778a2a0df6abf505fd8b20a503414e0')
+
+build()
+{
+ /bin/true
+}
+
+package()
+{
+ cd ${srcdir}
+ bsdtar -xf cs_CZ.zip
+ install -D -m 644 cs_CZ.aff ${pkgdir}/usr/share/myspell/dicts/cs_CZ.aff
+ install -D -m 644 cs_CZ.dic ${pkgdir}/usr/share/myspell/dicts/cs_CZ.dic
+
+ # symlinks are needed
+ install -dm755 ${pkgdir}/usr/share/hunspell
+ for file in ${pkgdir}/usr/share/myspell/dicts/*; do
+ ln -s /usr/share/myspell/dicts/$(basename $file) ${pkgdir}/usr/share/hunspell/$(basename $file)
+ done
+}