summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Ehlers Nyholm Thomsen2015-08-14 07:43:02 +0200
committerAdam Ehlers Nyholm Thomsen2015-08-14 07:44:27 +0200
commit5b4fc21f883d6c3fad05df15cdade395af2db605 (patch)
tree7367654bd31bdad77129e1b1adc23dafa6bb5bd6
downloadaur-5b4fc21f883d6c3fad05df15cdade395af2db605.tar.gz
Initial version (2.2)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72e67f84197b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hunspell-da
+ pkgdesc = Danish hunspell dictionaries
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://www.stavekontrolden.dk/
+ arch = any
+ license = GPL2
+ license = LGPL2.1
+ license = MPL1.1
+ optdepends = hunspell: the spell checking libraries and apps
+ source = http://extensions.libreoffice.org/extension-center/stavekontrolden-danish-dictionary/pscreleasefolder.2011-09-30.0280139318/2.2/dict-da-2-2.oxt
+ sha256sums = 16e0bc0ae9cf90b141b69e45f7d56a61d6629542661bea03d79efb8912a5938f
+
+pkgname = hunspell-da
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56e0eda954a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id$
+# Maintainer: adament <adament@adament.net>
+
+pkgname=hunspell-da
+pkgver=2.2
+pkgrel=1
+pkgdesc="Danish hunspell dictionaries"
+arch=(any)
+url="http://www.stavekontrolden.dk/"
+license=('GPL2' 'LGPL2.1' 'MPL1.1')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=(http://extensions.libreoffice.org/extension-center/stavekontrolden-danish-dictionary/pscreleasefolder.2011-09-30.0280139318/$pkgver/dict-da-${pkgver/./-}.oxt)
+sha256sums=('16e0bc0ae9cf90b141b69e45f7d56a61d6629542661bea03d79efb8912a5938f')
+
+package() {
+ cd "$srcdir"
+ install -dm755 ${pkgdir}/usr/share/hunspell
+ install -m644 da_DK.dic da_DK.aff $pkgdir/usr/share/hunspell
+
+ # the symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd $pkgdir/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename $file) .
+ done
+ popd
+}