summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Tam2020-10-14 22:39:23 +0800
committerChris Tam2020-10-14 22:39:23 +0800
commita9a6ff8d3ff2dab164ea6f3e71db9f1d0554d7b0 (patch)
treeff120afa3dfff74dc42a7f948a5c5c042dea72e3
downloadaur-a9a6ff8d3ff2dab164ea6f3e71db9f1d0554d7b0.tar.gz
Initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3726fcc3807e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hunspell-en-med-glut-git
+ pkgdesc = Hunspell dictionary of English medical terms
+ pkgver = r7.ad719a9
+ pkgrel = 1
+ url = https://github.com/glutanimate/hunspell-en-med-glut
+ arch = any
+ license = GPL3
+ optdepends = hunspell: the spell checking libraries and apps
+ source = git+https://github.com/glutanimate/hunspell-en-med-glut.git
+ sha1sums = SKIP
+
+pkgname = hunspell-en-med-glut-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e00f32202a89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Chris Tam <LChris314 at gmail dot com>
+
+pkgname=hunspell-en-med-glut-git
+pkgver=r7.ad719a9
+pkgrel=1
+pkgdesc="Hunspell dictionary of English medical terms"
+arch=(any)
+url="https://github.com/glutanimate/hunspell-en-med-glut"
+license=('GPL3')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=("git+${url}.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname%-git}"
+ _dic_file=en_med_glut.dic
+
+ install -dm755 "${pkgdir}/usr/share/hunspell"
+ install -m644 "$_dic_file" "${pkgdir}/usr/share/hunspell"
+
+ # myspell symlinks
+ install -dm755 "${pkgdir}/usr/share/myspell/dicts"
+ pushd "${pkgdir}/usr/share/myspell/dicts"
+ ln -sv "/usr/share/hunspell/${_dic_file}" .
+ popd
+
+ # licenses
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-git}/"
+}