summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorariasuni2016-12-04 05:30:03 +0100
committerariasuni2016-12-04 05:30:03 +0100
commit85143a15b6de6acca76feb1760f8dfda4f1601b2 (patch)
tree0590756dbc4cc8ad75c0cf58a613dc28e27e7339
downloadaur-85143a15b6de6acca76feb1760f8dfda4f1601b2.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a46ca93c8f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hunspell-eo
+ pkgdesc = Esperanto hunspell dictionary
+ pkgver = 20100216
+ pkgrel = 1
+ url = http://www.esperantilo.org/
+ arch = any
+ license = GPL2
+ optdepends = hunspell: the spell checking libraries and apps
+ source = http://www.esperantilo.org/literumilo-fontoj.tar.gz
+ md5sums = a190ad0995cb13b307ba968e7662ee9c
+
+pkgname = hunspell-eo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ec4cadda487
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
+# Based on hunspell-* PKGBUILDs
+
+pkgname=hunspell-eo
+pkgver=20100216
+pkgrel=1
+pkgdesc="Esperanto hunspell dictionary"
+arch=(any)
+url="http://www.esperantilo.org/"
+license=('GPL2')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=("http://www.esperantilo.org/literumilo-fontoj.tar.gz")
+md5sums=('a190ad0995cb13b307ba968e7662ee9c')
+
+package() {
+ cd "${srcdir}"
+ install -dm755 ${pkgdir}/usr/share/hunspell
+ install -m644 literumilo-fontoj/eo_cxorig.dic ${pkgdir}/usr/share/hunspell/eo.dic
+ install -m644 literumilo-fontoj/eo_cxorig.aff ${pkgdir}/usr/share/hunspell/eo.aff
+
+ pushd ${pkgdir}/usr/share/hunspell/
+
+ popd
+
+ # the symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd ${pkgdir}/usr/share/myspell/dicts
+ for file in ${pkgdir}/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename ${file}) .
+ done
+ popd
+}