summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Mousavi2017-07-10 21:13:54 +0430
committerAli Mousavi2017-07-10 21:13:54 +0430
commit358063abc410dbb27f57cee597214810dd65d122 (patch)
tree35eb7da15ba9f3febfa8e859c7878dc036f48c41
downloadaur-358063abc410dbb27f57cee597214810dd65d122.tar.gz
Initial package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD49
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef93cf4e296e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hunspell-fa
+ pkgdesc = Persian dictionaries for hunspell
+ pkgver = 0.11
+ pkgrel = 1
+ url = http://ftp.gnu.org/gnu/aspell/dict/0index.html
+ arch = any
+ license = LGPL2
+ makedepends = hunspell
+ makedepends = aspell
+ optdepends = hunspell: the spell checking libraries and apps
+ provides = hunspell-fa
+ source = http://ftp.gnu.org/gnu/aspell/dict/fa/aspell6-fa-0.11-0.tar.bz2
+ sha256sums = 482d26ea879a8ea02d9373952205f67e07c85a7550841b13b5079bb2f9f2e15b
+
+pkgname = hunspell-fa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..829c7368cf37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Ali Mousavi <ali.mousavi[at]gmail[dot]com>
+# https://github.com/tuxitop/PKGBUILDs
+
+pkgname=hunspell-fa
+pkgver=0.11
+pkgrel=1
+pkgdesc="Persian dictionaries for hunspell"
+url="http://ftp.gnu.org/gnu/aspell/dict/0index.html"
+arch=(any)
+license=("LGPL2")
+depends=()
+makedepends=("hunspell" "aspell")
+optdepends=("hunspell: the spell checking libraries and apps")
+provides=("${pkgname}")
+source=("http://ftp.gnu.org/gnu/aspell/dict/fa/aspell6-fa-${pkgver}-0.tar.bz2")
+sha256sums=("482d26ea879a8ea02d9373952205f67e07c85a7550841b13b5079bb2f9f2e15b")
+
+prepare() {
+ cd "${srcdir}/aspell6-fa-${pkgver}-0"
+
+ msg "converting aspell dictionaries..."
+ LANG=fa_IR.utf8 preunzip -d *.cwl
+ cat *.wl > persian.wordlist
+ wordlist2hunspell persian.wordlist fa_IR
+}
+
+ package() {
+ cd "${srcdir}/aspell6-fa-${pkgver}-0"
+
+ install -dm755 $pkgdir/usr/share/hunspell
+ install -m644 fa_IR.dic fa_IR.aff $pkgdir/usr/share/hunspell
+
+ # symlinks
+ install -dm755 $pkgdir/usr/share/myspell/dicts
+ ln -s /usr/share/hunspell/fa_IR.dic $pkgdir/usr/share/myspell/dicts/
+ ln -s /usr/share/hunspell/fa_IR.aff $pkgdir/usr/share/myspell/dicts/
+
+ # docs
+ install -dm755 $pkgdir/usr/share/doc/$pkgname
+ install -m644 README $pkgdir/usr/share/doc/$pkgname
+
+ # licenses
+ install -dm755 $pkgdir/usr/share/licenses/$pkgname
+ install -m644 Copyright $pkgdir/usr/share/licenses/$pkgname
+ install -m644 COPYING $pkgdir/usr/share/licenses/$pkgname
+}
+
+# vim:set ts=2 sw=2 et:
+