summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksel2021-01-26 12:46:45 +0100
committeraksel2021-01-26 12:46:45 +0100
commitede0a298dea19e2f0d20dc4232825591b1817168 (patch)
tree15834b769d59c868528b5345eabdeae70e7708e6
downloadaur-ede0a298dea19e2f0d20dc4232825591b1817168.tar.gz
hunspell-fo 0.4.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fa4639578b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hunspell-fo
+ pkgdesc = Faroese hunspell dictionaries
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://fo.speling.org/
+ arch = any
+ license = GPL2
+ license = LGPL2.1
+ license = MPL
+ optdepends = hunspell: the spell checking libraries and apps
+ source = hunspell-fo-0.4.2.tar.gz::https://fo.speling.org/filer/myspell-fo-0.4.2.tar.gz
+ sha256sums = SKIP
+
+pkgname = hunspell-fo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0fb27553fb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: aksel <aksel@akseltorgard.com>
+# Based on hunspell-* PKGBUILDs
+
+pkgname=hunspell-fo
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="Faroese hunspell dictionaries"
+arch=('any')
+url="https://fo.speling.org/"
+license=('GPL2' 'LGPL2.1' 'MPL')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=("${pkgname}-${pkgver}.tar.gz::https://fo.speling.org/filer/myspell-fo-${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/myspell-fo-${pkgver}"
+ install -dm755 "${pkgdir}"/usr/share/hunspell
+ install -m644 fo_FO.dic fo_FO.aff $pkgdir/usr/share/hunspell
+
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd "$pkgdir"/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/"$(basename $file)" .
+ done
+ popd
+}