summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-11-19 22:26:16 +0800
committerChocobo12018-11-19 22:38:12 +0800
commite463527e476f073400011bf9df4d7d9412828219 (patch)
tree9126b2e6fd70d51d50ec35de52439943ef76b64e
downloadaur-e463527e476f073400011bf9df4d7d9412828219.tar.gz
newpkg: hunspell-git 1.7.0.r0.g4ddd8ed-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD51
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65c015a23188
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hunspell-git
+ pkgdesc = The most popular spellchecking library
+ pkgver = 1.7.0.r0.g4ddd8ed
+ pkgrel = 1
+ url = https://hunspell.github.io/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ depends = ncurses
+ depends = readline
+ optdepends = perl: for ispellaff2myspell
+ provides = hunspell
+ conflicts = hunspell
+ options = staticlibs
+ source = git+https://github.com/hunspell/hunspell.git
+ sha256sums = SKIP
+
+pkgname = hunspell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4461b07f04db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=hunspell-git
+pkgver=1.7.0.r0.g4ddd8ed
+pkgrel=1
+pkgdesc="The most popular spellchecking library"
+arch=('i686' 'x86_64')
+url="https://hunspell.github.io/"
+license=('LGPL')
+depends=('glibc' 'ncurses' 'readline')
+makedepends=('git')
+optdepends=('perl: for ispellaff2myspell')
+provides=('hunspell')
+conflicts=('hunspell')
+options=('staticlibs')
+source=("git+https://github.com/hunspell/hunspell.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "hunspell"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "hunspell"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr" \
+ --with-readline \
+ --with-ui
+ make
+}
+
+check() {
+ cd "hunspell"
+
+ make check
+}
+
+package() {
+ cd "hunspell"
+
+ make DESTDIR="$pkgdir" install
+
+ # add generic hunspell.so for development and projects not using pkgconfig flags - FS#30592
+ cd "$pkgdir/usr/lib"
+ ln -s libhunspell-?.?.so "libhunspell.so"
+}