summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitrum2018-06-06 09:23:01 +0300
committerVitrum2018-06-06 09:23:01 +0300
commite5806a12f2d09a67a0bdf9aa8b6decdb652bbf26 (patch)
tree5ff6373f772008de3d3e28f2d38311bd321f2bb2
downloadaur-e5806a12f2d09a67a0bdf9aa8b6decdb652bbf26.tar.gz
v3.0.1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD62
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c3f4689ec46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = hunspell-hy
+ pkgdesc = Armenian hunspell dictionaries
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = https://github.com/hyspell/
+ arch = any
+ license = MIT
+ optdepends = hunspell: the spell checking libraries and apps
+ source = https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/Dictc/hy-c.aff
+ source = https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/Dictc/hy-c.dic
+ source = https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/Dictr/hy-r.aff
+ source = https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/Dictr/hy-r.dic
+ source = https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/license.txt
+ sha1sums = d01c0c802013115c7701c04425f865f3aa78743b
+ sha1sums = da1c9f8c51b77b16789c4473756d688e691b74c8
+ sha1sums = 77d9996d4d1b50ac1134d2882ad51e53968ee7c6
+ sha1sums = cfd078f93c44e9b9a5f1a27fb04bd4e7763ee2ae
+ sha1sums = 04fa1d9d0b8017e2877b1d338d4ff862cd540002
+
+pkgname = hunspell-hy-classical
+ pkgdesc = Armenian hunspell dictionaries. Classical Orthography.
+
+pkgname = hunspell-hy-reformed
+ pkgdesc = Armenian hunspell dictionaries. Reformed Orthography.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40a6105a3176
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+
+pkgbase=hunspell-hy
+pkgname=('hunspell-hy-classical' 'hunspell-hy-reformed')
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="Armenian hunspell dictionaries"
+arch=(any)
+url="https://github.com/hyspell/"
+license=('MIT')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=(
+ 'https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/Dictc/hy-c.aff'
+ 'https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/Dictc/hy-c.dic'
+ 'https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/Dictr/hy-r.aff'
+ 'https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/Dictr/hy-r.dic'
+ 'https://raw.githubusercontent.com/hyspell/HySpell_3.0.1/master/Dictionaries/license.txt'
+)
+sha1sums=('d01c0c802013115c7701c04425f865f3aa78743b'
+ 'da1c9f8c51b77b16789c4473756d688e691b74c8'
+ '77d9996d4d1b50ac1134d2882ad51e53968ee7c6'
+ 'cfd078f93c44e9b9a5f1a27fb04bd4e7763ee2ae'
+ '04fa1d9d0b8017e2877b1d338d4ff862cd540002')
+
+prepare() {
+ # add WORDCHARS and IGNORE lines
+ sed -i '4i\\nWORDCHARS ֊՛՜՞՚\nIGNORE ֊՛՜՞՚' ./hy-c.aff
+ sed -i '4i\\nWORDCHARS ֊՛՜՞՚\nIGNORE ֊՛՜՞՚' ./hy-r.aff
+}
+
+package_hunspell-hy-classical() {
+ pkgdesc="Armenian hunspell dictionaries. Classical Orthography."
+
+ cd "$srcdir"
+ install -dm755 ${pkgdir}/usr/share/hunspell
+ install -m644 hy-c.aff $pkgdir/usr/share/hunspell/hy_AM.aff
+ install -m644 hy-c.dic $pkgdir/usr/share/hunspell/hy_AM.dic
+ package_common
+}
+
+package_hunspell-hy-reformed() {
+ pkgdesc="Armenian hunspell dictionaries. Reformed Orthography."
+
+ cd "$srcdir"
+ install -dm755 ${pkgdir}/usr/share/hunspell
+ install -m644 hy-r.aff $pkgdir/usr/share/hunspell/hy_AM.aff
+ install -m644 hy-r.dic $pkgdir/usr/share/hunspell/hy_AM.dic
+ package_common
+}
+
+package_common() {
+ # the symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd $pkgdir/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename $file) .
+ done
+ popd
+
+ # licenses
+ install -D -m644 license.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}