summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlga Smirnova2017-02-13 23:11:40 +0700
committerOlga Smirnova2017-02-13 23:11:40 +0700
commitd22d71446c101a0684591bd7254da9d32736b952 (patch)
tree2144fbad57c9d2da2250e8a9c09cf97737e6a05e
downloadaur-d22d71446c101a0684591bd7254da9d32736b952.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d20402b1004e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hunspell-ie
+ pkgdesc = Interlingue hunspell dictionary
+ pkgver = 0.6
+ pkgrel = 1
+ url = http://github.com/Carmina16/hunspell-ie
+ arch = any
+ license = Apache
+ optdepends = hunspell: the spell checking libraries and apps
+ source = https://github.com/Carmina16/hunspell-ie/archive/v0.6.tar.gz
+ md5sums = 94929cf2bdbed5ad5aaac932550d34ad
+
+pkgname = hunspell-ie
+
+pkgname = hyphen-ie
+ pkgdesc = Interlingue hyphenation rules
+ optdepends = hyphen: library for hyphenation and justification
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0845917f6dee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Olga Smirnova <mistresssilvara@hotmail.com>
+pkgbase='hunspell-ie'
+pkgname=('hunspell-ie' 'hyphen-ie')
+pkgver=0.6
+pkgrel=1
+pkgdesc="Interlingue hunspell dictionary"
+arch=('any')
+url="http://github.com/Carmina16/hunspell-ie"
+license=('Apache')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=('https://github.com/Carmina16/hunspell-ie/archive/v0.6.tar.gz')
+md5sums=('94929cf2bdbed5ad5aaac932550d34ad')
+
+package_hunspell-ie() {
+ cd "$srcdir/${pkgbase}-${pkgver}"
+ install -d -m 755 "$pkgdir/usr/share/hunspell"
+ install -m 644 ie.{aff,dic} "$pkgdir/usr/share/hunspell"
+}
+
+package_hyphen-ie() {
+ optdepends=('hyphen: library for hyphenation and justification')
+ pkgdesc="Interlingue hyphenation rules"
+
+ cd "$srcdir/${pkgbase}-${pkgver}"
+ install -d -m 755 "$pkgdir/usr/share/hunspell"
+ install -m 644 hyph_ie.dic "$pkgdir/usr/share/hunspell"
+}
+