summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSungjoon Moon2020-11-19 05:31:03 +0900
committerSungjoon Moon2020-11-19 05:31:03 +0900
commite73ba6c43df64cbc366c3c5728991b29d4e95e76 (patch)
treefd48573e33a1459fa9cb428875468d24d3e22c07
parentb7fd66d324ab0bc00c74a0677187013e4a965950 (diff)
downloadaur-e73ba6c43df64cbc366c3c5728991b29d4e95e76.tar.gz
added symlinks and licenses
-rw-r--r--PKGBUILD39
1 files changed, 27 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea40981cc9ad..0b58f556dc44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,42 @@
-# Maintainer: changwoo
# Maintainer: OctopusET
pkgname=hunspell-ko
-pkgver=0.7.1
-pkgrel=4
+pkgver=0.7.92
+pkgrel=1
pkgdesc="Korean dictionary for hunspell"
arch=('any')
-url='http://code.google.com/p/spellcheck-ko'
-license=('LGPL3' 'MPL' 'GPL' 'CC BY-SA 4.0')
+url='https://github.com/spellcheck-ko/hunspell-dict-ko'
+license=('GPL3' 'custom')
depends=('hunspell>=1.3.1')
makedepends=(
- 'python>=3.5'
+'python-yaml'
)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/spellcheck-ko/hunspell-dict-ko/archive/${pkgver}.tar.gz")
-sha1sums=('e93dd247b629acb3c33e062fa0153bb3188c9b86')
-
+sha1sums=('41085dac1529224d96bfef13fa7fc836aeee5bda')
build() {
cd "$srcdir/hunspell-dict-ko-$pkgver"
make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX=/usr
}
package() {
- cd "$srcdir/hunspell-dict-ko-$pkgver"
- install -dm755 "${pkgdir}"/usr/share/hunspell
- cp -p ko.aff "${pkgdir}"/usr/share/hunspell/ko_KR.aff
- cp -p ko.dic "${pkgdir}"/usr/share/hunspell/ko_KR.dic
+ cd "$srcdir/hunspell-dict-ko-$pkgver"
+ install -dm755 "${pkgdir}/usr/share/hunspell"
+ install -m644 ko.dic "${pkgdir}"/usr/share/hunspell
+ install -m644 ko.aff "${pkgdir}"/usr/share/hunspell
+ pushd "$pkgdir"/usr/share/hunspell
+ for file in ko.*; do
+ ln -s ko_KR."${file#*.}"
+ done
+ popd
+
+# symlinks
+ install -dm755 "${pkgdir}"/usr/share/myspell/dicts
+ pushd "$pkgdir"/usr/share/myspell/dicts
+ for file in "${pkgdir}"/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename $file) .
+ done
+ popd
+
+# licenses
+ install -Dm644 LICENSE.md $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
}