summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrejs Mivreņiks2015-08-31 21:00:24 +0300
committerAndrejs Mivreņiks2015-08-31 21:00:24 +0300
commit3766cd8922d7a1adc6e2310b389254f4d9dc6362 (patch)
tree33fb806c02d3b633afcc74258de2618d9ea13626
parent9ef3171456546515a41c03f4901e95e24a639c43 (diff)
downloadaur-3766cd8922d7a1adc6e2310b389254f4d9dc6362.tar.gz
Clean up the PKGBUILD a bit
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56fc57bef99c..6832a985a80a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v7
+# Mon Aug 31 17:59:42 UTC 2015
pkgbase = hunspell-lv
pkgdesc = Latvian hunspell dictionary
pkgver = 1.1.0
diff --git a/PKGBUILD b/PKGBUILD
index 705bb6a5eec4..b7a6dcfbb952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
pkgname=hunspell-lv
pkgver=1.1.0
pkgrel=1
-pkgdesc="Latvian hunspell dictionary"
+pkgdesc='Latvian hunspell dictionary'
arch=('any')
-url="http://dict.dv.lv/download.php?prj=lv"
+url='http://dict.dv.lv/download.php?prj=lv'
license=('LGPL2')
depends=('hunspell' 'hyphen')
-source=("http://dict.dv.lv/download/lv_LV-$pkgver.zip")
+source=("http://dict.dv.lv/download/lv_LV-${pkgver}.zip")
sha256sums=('1845ee1ce23614ccb0ad29b1441827a53d137d7afdd7d40a835e996e8f899aa3')
package() {
- cd "$srcdir"
- install -D -m 644 lv_LV.aff "${pkgdir}/usr/share/hunspell/lv_LV.aff"
- install -D -m 644 lv_LV.dic "${pkgdir}/usr/share/hunspell/lv_LV.dic"
- install -d -m 755 ${pkgdir}/usr/share/myspell/dicts
- ln -s /usr/share/hunspell/lv_LV.aff "${pkgdir}/usr/share/myspell/dicts"
- ln -s /usr/share/hunspell/lv_LV.dic "${pkgdir}/usr/share/myspell/dicts"
- install -D -m 644 hyph_lv_LV.dic "${pkgdir}/usr/share/hyphen/hyph_lv_LV.dic"
- install -D -m 644 "README_lv_LV.txt" "${pkgdir}/usr/share/doc/hunspell-lv/README.txt"
- install -D -m 644 "README_hyph_lv_LV.txt" "${pkgdir}/usr/share/doc/hunspell-lv/README_hyph.txt"
+ install -Dm644 lv_LV.aff "$pkgdir/usr/share/hunspell/lv_LV.aff"
+ install -Dm644 lv_LV.dic "$pkgdir/usr/share/hunspell/lv_LV.dic"
+
+ install -dm755 "$pkgdir/usr/share/myspell/dicts"
+ ln -s /usr/share/hunspell/lv_LV.aff "$pkgdir/usr/share/myspell/dicts"
+ ln -s /usr/share/hunspell/lv_LV.dic "$pkgdir/usr/share/myspell/dicts"
+
+ install -Dm644 hyph_lv_LV.dic "$pkgdir/usr/share/hyphen/hyph_lv_LV.dic"
+ install -Dm644 README_lv_LV.txt "$pkgdir/usr/share/doc/hunspell-lv/README.txt"
+ install -Dm644 README_hyph_lv_LV.txt "$pkgdir/usr/share/doc/hunspell-lv/README_hyph.txt"
}
-# vim:set ts=2 sw=2 et: