summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMauro Santos2015-06-25 22:50:47 +0100
committerMauro Santos2015-06-25 23:01:52 +0100
commite98425cd43e42fda422b739d5ad8e6b89429ca04 (patch)
tree6ae349753b64a67bd7151cec193840fb034eee87
downloadaur-e98425cd43e42fda422b739d5ad8e6b89429ca04.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8c9ec8ac2b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hunspell-pt_pt
+ pkgdesc = Portuguese (European, post-orthographic agreement) hunspell dictionaries
+ pkgver = 20150418
+ pkgrel = 1
+ url = http://natura.di.uminho.pt/download/sources/Dictionaries/hunspell/
+ arch = any
+ license = GPL
+ license = LGPL
+ license = MPL
+ optdepends = hunspell: the spell checking libraries and apps
+ source = http://natura.di.uminho.pt/download/sources/Dictionaries/hunspell/hunspell-pt_PT-20150418.tar.gz
+ md5sums = 27b19be9c318156339a8cfb217f17476
+
+pkgname = hunspell-pt_pt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06acc46a846c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mauro Santos <registo.mailling@gmail.com>
+
+pkgname='hunspell-pt_pt'
+_pkgname='hunspell-pt_PT'
+pkgver=20150418
+pkgrel=1
+pkgdesc="Portuguese (European, post-orthographic agreement) hunspell dictionaries"
+arch=('any')
+url="http://natura.di.uminho.pt/download/sources/Dictionaries/hunspell/"
+license=('GPL' 'LGPL' 'MPL')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=("http://natura.di.uminho.pt/download/sources/Dictionaries/hunspell/$_pkgname-$pkgver.tar.gz")
+md5sums=('27b19be9c318156339a8cfb217f17476')
+
+build() {
+ /bin/true
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ install -dm755 $pkgdir/usr/share/hunspell
+ install -m644 pt_PT.* $pkgdir/usr/share/hunspell
+
+ # the symlinks
+ install -dm755 $pkgdir/usr/share/myspell/dicts
+ pushd $pkgdir/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename ${file}) .
+ done
+ popd
+
+ # docs
+ install -dm755 $pkgdir/usr/share/doc/$pkgname
+ install -m644 README_pt_PT.txt $pkgdir/usr/share/doc/$pkgname
+
+ # licences
+ install -dm755 $pkgdir/usr/share/licenses/$pkgname/
+ install -m644 COPYING $pkgdir/usr/share/licenses/$pkgname
+}