summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrần Nam Tuấn2022-08-30 20:46:44 +0700
committerTrần Nam Tuấn2022-08-30 20:46:44 +0700
commit646c9ae6cd8d2191705b748d7ff8c4624abf5635 (patch)
treeeaa35a44332d8dfcd0528b47867e85547f18c328
downloadaur-646c9ae6cd8d2191705b748d7ff8c4624abf5635.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31a65c96bfec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hunspell-vi-git
+ pkgdesc = Vietnamese dictionaries for Hunspell
+ pkgver = v2.2.0.r35.g507d07e
+ pkgrel = 1
+ url = https://github.com/1ec5/hunspell-vi.git
+ arch = x86_64
+ license = GPL3
+ depends = hunspell
+ provides = hunspell-vi
+ conflicts = hunspell-vi
+ source = git+https://github.com/1ec5/hunspell-vi.git
+ sha256sums = SKIP
+
+pkgname = hunspell-vi-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eb82a6e3a96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: TheBill2001 <tuantran1632001 at gmail dot com>
+
+pkgname=hunspell-vi-git
+provides=('hunspell-vi')
+conflicts=('hunspell-vi')
+pkgver=v2.2.0.r35.g507d07e
+pkgrel=1
+pkgdesc="Vietnamese dictionaries for Hunspell"
+arch=('x86_64')
+url="https://github.com/1ec5/hunspell-vi.git"
+license=('GPL3')
+depends=('hunspell')
+source=("git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/hunspell-vi"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
+package() {
+ cd "${srcdir}/hunspell-vi/dictionaries"
+ install -D -m644 "vi-DauMoi.dic" "${pkgdir}/usr/share/hunspell/vi_VN.dic"
+ install -D -m644 "vi-DauMoi.aff" "${pkgdir}/usr/share/hunspell/vi_VN.aff"
+
+ install -d -m755 "${pkgdir}/usr/share/myspell/dicts"
+ ln -sv "/usr/share/hunspell/vi_VN.dic" "${pkgdir}/usr/share/myspell/dicts/vi_VN.dic"
+ ln -sv "/usr/share/hunspell/vi_VN.aff" "${pkgdir}/usr/share/myspell/dicts/vi_VN.aff"
+}