summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-12-16 20:24:55 +0100
committerhaawda2022-12-16 20:24:55 +0100
commit460fdf4297739c5bfe28825644938b3d93f9398a (patch)
tree64c6506d3b08af04cae6809976cf481a6a5cb3ce
parent0a68a51c717758fe03357b71b7ae6b3896d0f372 (diff)
downloadaur-460fdf4297739c5bfe28825644938b3d93f9398a.tar.gz
use a fixed fork
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7131693935d..9b2f06187f77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = hunter
pkgdesc = Ranger-like CLI file browser written in Rust
pkgver = 1.3.5
- pkgrel = 2
- url = https://github.com/rabite0/hunter
+ pkgrel = 3
+ url = https://github.com/nanoctr/hunter
arch = i686
arch = x86_64
license = custom:WTFPL
+ makedepends = git
makedepends = rustup
makedepends = gst-plugins-good
makedepends = gst-plugins-bad
@@ -30,8 +31,7 @@ pkgbase = hunter
optdepends = mupdf-tools: PDF support
optdepends = fzf: Default file finder
provides = hunter
- source = hunter-1.3.5.tar.gz::https://github.com/rabite0/hunter/archive/v1.3.5.tar.gz
- sha256sums = f0f9bf2b4defeeb83e339b984407eb717cb1cb9fffb358e65780e89aa72c906a
+ source = git+https://github.com/nanoctr/hunter.git#commit=17946cf
+ sha256sums = SKIP
pkgname = hunter
-
diff --git a/PKGBUILD b/PKGBUILD
index 4cd341f67837..c4ca5ec820df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: Jean Lucas <jean@4ray.co>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=hunter
pkgver=1.3.5
-pkgrel=2
+pkgrel=3
pkgdesc='Ranger-like CLI file browser written in Rust'
arch=('i686' 'x86_64')
-url='https://github.com/rabite0/hunter'
+url='https://github.com/nanoctr/hunter'
license=('custom:WTFPL')
provides=('hunter')
depends=('gst-plugins-base-libs' 'libsixel')
-makedepends=('rustup'
+makedepends=('git'
+ 'rustup'
'gst-plugins-good'
'gst-plugins-bad'
'gst-plugins-ugly')
@@ -31,18 +33,18 @@ optdepends=('gst-plugins-good: Media support'
'poppler: PDF support'
'mupdf-tools: PDF support'
'fzf: Default file finder')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('f0f9bf2b4defeeb83e339b984407eb717cb1cb9fffb358e65780e89aa72c906a')
+source=("git+${url}.git#commit=17946cf")
+sha256sums=('SKIP')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
rustup override set nightly
cargo build --release
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
install -D target/release/hunter{,-media} -t "${pkgdir}"/usr/bin
install -Dm644 README.md -t "${pkgdir}"/usr/share/doc/hunter
install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/hunter
-} \ No newline at end of file
+}