summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-10 02:52:50 -0400
committerJean Lucas2019-08-10 02:52:50 -0400
commitb29785fcc889cc9b81d0de75babf13532c13c632 (patch)
treef544bca367eef091436bc652fe19986e43f6b3ad
parent49f24dea2e6f2e4b9ea7b6581380b16886dfd4ef (diff)
downloadaur-b29785fcc889cc9b81d0de75babf13532c13c632.tar.gz
Fix/update deps/binaries, install Rust nightly if needed, 1.3.4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD22
2 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 221e3b859f01..3e5b5df87aa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = hunter
pkgdesc = ranger-like file browser written in Rust
- pkgver = 1.2.3
- pkgrel = 2
+ pkgver = 1.3.4
+ pkgrel = 1
url = https://github.com/rabite0/hunter
arch = i686
arch = x86_64
license = WTFPL
- makedepends = rust-nightly
- depends = file
+ makedepends = rustup
depends = xdg-utils
- depends = gst-plugins-bad
- depends = gst-plugins-ugly
- depends = gst-libav
+ depends = gst-plugins-base
+ optdepends = gst-plugins-bad: media support
+ optdepends = gst-plugins-ugly: media support
+ optdepends = gst-libav: media support
+ optdepends = libsixel: media support
optdepends = nerd-fonts-complete: supported icon pack
optdepends = bat: syntax highlighting
optdepends = highlight: syntax highlighting
+ optdepends = libarchive: archive support
optdepends = p7zip: archive support
optdepends = w3m: HTML support
optdepends = links: HTML support
@@ -22,8 +24,8 @@ pkgbase = hunter
optdepends = lynx: HTML support
optdepends = poppler: PDF support
optdepends = mupdf-tools: PDF support
- source = https://github.com/rabite0/hunter/archive/v1.2.3.tar.gz
- sha512sums = 507cb50fa5d8243c95fa1f12c008541d5b0edd7a8353f47be7dce53e771e3a469405426d332d8e23181dfb4b5e3e2fbbe906bc2d48c8e2ca3f905f6325b4ae94
+ source = https://github.com/rabite0/hunter/archive/v1.3.4.tar.gz
+ sha512sums = dc7d4167037a08645f0480714eb864e5aad99957bd8177d963ad890e258323bf21ec6874bbe4f6cefb337ac0215b8304829d539fbfdc017d8c4fc1a346e47997
pkgname = hunter
diff --git a/PKGBUILD b/PKGBUILD
index 2444c9aefd28..d5f2d69bb58d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter
-pkgver=1.2.3
-pkgrel=2
+pkgver=1.3.4
+pkgrel=1
pkgdesc='ranger-like file browser written in Rust'
arch=(i686 x86_64)
url=https://github.com/rabite0/hunter
license=(WTFPL)
-depends=(file xdg-utils gst-plugins-bad gst-plugins-ugly gst-libav)
-makedepends=(rust-nightly)
-optdepends=('nerd-fonts-complete: supported icon pack'
+depends=(xdg-utils gst-plugins-base)
+makedepends=(rustup)
+optdepends=('gst-plugins-bad: media support'
+ 'gst-plugins-ugly: media support'
+ 'gst-libav: media support'
+ 'libsixel: media support'
+ 'nerd-fonts-complete: supported icon pack'
'bat: syntax highlighting'
'highlight: syntax highlighting'
+ 'libarchive: archive support'
'p7zip: archive support'
'w3m: HTML support'
'links: HTML support'
@@ -20,16 +25,17 @@ optdepends=('nerd-fonts-complete: supported icon pack'
'poppler: PDF support'
'mupdf-tools: PDF support')
source=($url/archive/v$pkgver.tar.gz)
-sha512sums=('507cb50fa5d8243c95fa1f12c008541d5b0edd7a8353f47be7dce53e771e3a469405426d332d8e23181dfb4b5e3e2fbbe906bc2d48c8e2ca3f905f6325b4ae94')
+sha512sums=('dc7d4167037a08645f0480714eb864e5aad99957bd8177d963ad890e258323bf21ec6874bbe4f6cefb337ac0215b8304829d539fbfdc017d8c4fc1a346e47997')
build() {
cd hunter-$pkgver
- cargo +nightly build --release
+ rustup override set nightly
+ cargo build --release
}
package() {
cd hunter-$pkgver
- install -D target/release/{hunter,preview-gen} extra/scope.sh -t "$pkgdir"/usr/bin
+ install -D target/release/hunter{,-media} -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}